Bug 1947653 (CVE-2021-3486)

Summary: CVE-2021-3486 glpi: Stored cross-site scripting via plugin metadata
Product: [Other] Security Response Reporter: Pedro Sampaio <psampaio>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED UPSTREAM QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: extras-orphan
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: glpi 9.5.5 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-04-08 23:35:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1947654    
Bug Blocks: 1947655    

Description Pedro Sampaio 2021-04-08 19:46:41 UTC
GLPi 9.5.4 does not sanitize the metadata. This is way its possible to insert XSS into plugins to execute JavaScript code. 

References:

https://github.com/Kitsun3Sec/exploits/tree/master/cms/GLPI/GLPI-stored-XSS
https://n3k00n3.github.io/blog/09042021/glpi_xss.html

Comment 1 Pedro Sampaio 2021-04-08 19:47:02 UTC
Created glpi tracking bugs for this issue:

Affects: fedora-32 [bug 1947654]

Comment 2 Product Security DevOps Team 2021-04-08 23:35:33 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.