Bug 1950489

Summary: The referred role doesn't exist if create rolebinding from rolebinding tab of role page
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: Management ConsoleAssignee: Samuel Padgett <spadgett>
Status: CLOSED ERRATA QA Contact: Yadan Pei <yapei>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.8CC: aos-bugs, jhadvig, jokerman, spadgett, yanpzhan, yapei
Target Milestone: ---   
Target Release: 4.7.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Previously, when creating a new binding from the role bindings tab of the role page, the web console would prefill the incorrect role name and namespace in the resulting form. This has been fixed.
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-05-19 15:16:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1949410    
Bug Blocks: 1950490    

Comment 2 Yadan Pei 2021-04-27 06:24:46 UTC
Launched a cluster using cluster-bot with PR #8685

1. cluster admin user goes to "User Management"->"Roles" page, click into role "cluster-admin".
2. create rolebinding by click "Create binding" on "RoleBindings" tab, now the "Role name" is set to "cluster-admin" by default.
3. Create either Namespace Rolebinding or Cluster Rolebinding, check the rolebinding YAML roleRef, now it is correctly set to ClusterRole cluster-admin
roleRef:
  apiGroup: rbac.authorization.k8s.io
  kind: ClusterRole
  name: cluster-admin

Comment 4 Yadan Pei 2021-05-07 02:09:51 UTC
PR has been verified before merging, moving to VERIFIED directly

Comment 7 errata-xmlrpc 2021-05-19 15:16:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1550