Bug 1954859

Summary: Some missing colour with less -R
Product: [Fedora] Fedora Reporter: Peter Oliver <mavit>
Component: lessAssignee: Matej Mužila <mmuzila>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 34CC: fjanus, fpokorny, hhorak, jmlich83, kasal, mmuzila, odubaj, praiskup, rwf, viktor.vix.jancik
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: less-581.2-1.fc34 Doc Type: ---
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-05-08 01:34:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Peter Oliver 2021-04-28 22:47:24 UTC
Description of problem:
Colour is missing in some places when using less.

Version-Release number of selected component (if applicable):
575-2.fc34

How reproducible:
Always, but not in all places in a given file.

Steps to Reproduce:
1. ack foo [this is piped to less]
2. ack --nopager foo [this goes straight to the terminal]
3. Compare the outputs

Actual results:
Some of the colour is missing when piped to less.

Expected results:
Both look the same.

Additional info:
I tried this with the latest release, 581.2, and the bug was gone.

Comment 1 Rob Foehl 2021-05-04 07:28:49 UTC
Hit the same issue, with grep output going entirely missing due to its use of \e[K line-clearing sequences.  See https://github.com/gwsw/less/issues/140 for details.

Comment 2 Fedora Update System 2021-05-06 09:36:32 UTC
FEDORA-2021-50ffffcdd9 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-50ffffcdd9

Comment 3 Fedora Update System 2021-05-07 02:07:21 UTC
FEDORA-2021-50ffffcdd9 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-50ffffcdd9`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-50ffffcdd9

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2021-05-08 01:34:14 UTC
FEDORA-2021-50ffffcdd9 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.