Bug 1955715

Summary: Some on-prem namespaces missing from must-gather
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: Machine Config OperatorAssignee: Ben Nemec <bnemec>
Status: CLOSED ERRATA QA Contact: Michael Nguyen <mnguyen>
Severity: high Docs Contact:
Priority: high    
Version: 4.8Keywords: Triaged
Target Milestone: ---   
Target Release: 4.6.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: Missing settings for must-gather Consequence: Some namespaces were not captured in must-gather Fix: Added necessary settings Result: All relevant namespaces are present in must-gather
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-06-08 13:54:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1950498    
Bug Blocks:    

Comment 5 Michael Nguyen 2021-06-01 16:13:49 UTC
Verified on 4.6.0-0.nightly-2021-05-31-074224


$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2021-05-31-074224   True        False         21m     Cluster version is 4.6.0-0.nightly-2021-05-31-074224


sent 69,900 bytes  received 128,764,913 bytes  8,885,159.52 bytes/sec
total size is 128,410,953  speedup is 1.00
clusterrolebinding.rbac.authorization.k8s.io/must-gather-4xfrr deleted
namespace/openshift-must-gather-qfrtz deleted
$ ls
README.md                                                        openshift-install-linux-4.6.0-0.nightly-2021-05-31-074224.tar.gz
must-gather.local.1584068985126209774                            release.txt
openshift-client-linux-4.6.0-0.nightly-2021-05-31-074224.tar.gz  sha256sum.txt
openshift-install                                                testcluster
$ cd must-gather.local.1584068985126209774/
[must-gather.local.1584068985126209774]$ ls
cluster-scoped-resources  etcd_info  event-filter.html  host_service_logs  namespaces  timestamp  version
[must-gather.local.1584068985126209774]$ cd namespaces/
[namespaces]$ ls 
default                                 openshift-console-operator                  openshift-kube-storage-version-migrator
kube-system                             openshift-controller-manager                openshift-kube-storage-version-migrator-operator
openshift                               openshift-controller-manager-operator       openshift-machine-api
openshift-apiserver                     openshift-dns                               openshift-machine-config-operator
openshift-apiserver-operator            openshift-dns-operator                      openshift-marketplace
openshift-authentication                openshift-etcd                              openshift-monitoring
openshift-authentication-operator       openshift-etcd-operator                     openshift-multus
openshift-cloud-credential-operator     openshift-image-registry                    openshift-network-operator
openshift-cluster-csi-drivers           openshift-ingress                           openshift-oauth-apiserver
openshift-cluster-machine-approver      openshift-ingress-operator                  openshift-openstack-infra
openshift-cluster-node-tuning-operator  openshift-insights                          openshift-operator-lifecycle-manager
openshift-cluster-samples-operator      openshift-kni-infra                         openshift-ovirt-infra
openshift-cluster-storage-operator      openshift-kube-apiserver                    openshift-sdn
openshift-cluster-version               openshift-kube-apiserver-operator           openshift-service-ca
openshift-config                        openshift-kube-controller-manager           openshift-service-ca-operator
openshift-config-managed                openshift-kube-controller-manager-operator  openshift-user-workload-monitoring
openshift-config-operator               openshift-kube-scheduler                    openshift-vsphere-infra

Comment 7 errata-xmlrpc 2021-06-08 13:54:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.32 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:2157