Bug 1956031

Summary: openldap-2.4.57-3.fc34 breaks lsi megaraid manager
Product: [Fedora] Fedora Reporter: Torbjorn Jansson <torbjorn>
Component: openldapAssignee: Simon Pichugin <spichugi>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 34CC: lance, rmeggins, spichugi, vashirov
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard:
Fixed In Version: openldap-2.4.57-4.fc34 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-06-14 01:05:44 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Torbjorn Jansson 2021-05-02 08:41:41 UTC
Description of problem:

package openldap-2.4.57-3.fc34 breaks lsi megaraid manager application.
trying to start LSA results in:

# ./LSA
./LSA: symbol lookup error: /lib64/libldap_r-2.4.so.2: undefined symbol: EVP_md2, version OPENSSL_1_1_0

downgrading to openldap-2.4.57-2.fc34 fixes the problem.


Version-Release number of selected component (if applicable):
broken: openldap-2.4.57-3.fc34
working: openldap-2.4.57-2.fc34


How reproducible:
100% reproducible with the broken packages

Steps to Reproduce:
1. install megaraid LSA
2. try to start, it fails, to see error start /opt/lsi/LSIStorageAuthority/bin/LSA manually
3.

Actual results:
program fails to start with above error

Expected results:
program starts

Comment 1 Simon Pichugin 2021-05-03 06:28:17 UTC
Hello,
could you please try two things:

1. Run "sudo ldconfig" command;
2. Update all of the packages (especially openssl).

Hope that helps,
Simon

Comment 2 Torbjorn Jansson 2021-05-03 06:42:08 UTC
ldconfig was run multiple times before downgrading the package and at the time (shortly before submitting this bug report) i had already made sure all packages was up to date.

Comment 3 Simon Pichugin 2021-05-03 08:42:35 UTC
What OpenSSL version do you have?
How exactly your package is named so we can try to reproduce it?

Comment 4 Torbjorn Jansson 2021-05-09 10:31:26 UTC
relevant packages and versions that is not working:

LSIStorageAuthority-007.016.009.000-00.x86_64

openldap-2.4.57-3.fc34.x86_64
openldap-clients-2.4.57-3.fc34.x86_64
openldap-compat-2.4.57-3.fc34.x86_64
openldap-devel-2.4.57-3.fc34.x86_64

openssl-1.1.1k-1.fc34.x86_64
openssl-devel-1.1.1k-1.fc34.x86_64
openssl-libs-1.1.1k-1.fc34.x86_64
openssl-pkcs11-0.4.11-2.fc34.x86_64



first one above can be downloaded from:
https://docs.broadcom.com/docs/007.016.009.000_LSA_Linux-x64.zip

trying to run:
/opt/lsi/LSIStorageAuthority/bin/LSA
results in:
/opt/lsi/LSIStorageAuthority/bin/LSA: symbol lookup error: /lib64/libldap_r-2.4.so.2: undefined symbol: EVP_md2, version OPENSSL_1_1_0

and this does not happen with openldap-2.4.57-2.fc34

Comment 5 Viktor Ashirov 2021-05-09 21:13:03 UTC
Thank you for the detailed information, I was able to reproduce it.

The regression comes from https://bugzilla.redhat.com/show_bug.cgi?id=1822904
In particular: https://src.fedoraproject.org/rpms/openldap/blob/rawhide/f/openldap-cbinding-ITS-9189_1-rework-sasl-cbinding-support.patch#_472-474

I've added -DOPENSSL_NO_MD2 to CFLAGS and built a test package: https://copr.fedorainfracloud.org/coprs/vashirov/openldap-bz1956031/
Could you please test it and check if this solves the issue for you?

Thanks.

Comment 6 Torbjorn Jansson 2021-05-14 12:16:53 UTC
Tested and appears to be working.
First i did a "dnf update" to make sure i got the broken packages and confirmed it was broken.
then installed the ones you prepared and did new test, seems to be working and no undefined symbol.

Comment 7 Fedora Update System 2021-06-04 14:03:40 UTC
FEDORA-2021-e42a313704 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-e42a313704

Comment 8 Fedora Update System 2021-06-05 01:10:03 UTC
FEDORA-2021-e42a313704 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-e42a313704`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-e42a313704

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2021-06-14 01:05:44 UTC
FEDORA-2021-e42a313704 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.