Bug 1956206

Summary: perl-Crypt-CBC-3.03-1.fc35 FTBFS on Perl bootstrap: Can't locate object method "keysize" via package "Crypt::IDEA" at t/nopadding.t line 40.
Product: [Fedora] Fedora Reporter: Petr Pisar <ppisar>
Component: perl-Crypt-CBCAssignee: Paul Howarth <paul>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: andreas, paul, perl-devel
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: perl-Crypt-CBC-3.03-2.fc35 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-05-03 13:07:02 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Petr Pisar 2021-05-03 08:11:59 UTC
perl-Crypt-CBC-3.03-1.fc35 fails to build when bootstrapping Perl because t/nopadding.t fails without perl-CryptX-0.053-19.fc35 having been installed:


$ perl -Ilib t/nopadding.t
1..2
using Crypt::IDEA for testing
ok 1
Can't locate object method "keysize" via package "Crypt::IDEA" at t/nopadding.t line 40.

Compare to an output after installing perl-CryptX:

$ perl -Ilib t/nopadding.t
1..2
using Crypt::Cipher::AES for testing
ok 1
ok 2

Comment 1 Paul Howarth 2021-05-03 13:02:24 UTC
Looks like Crypt::CBC uses Crypt::Cipher::AES as the default cipher unless you explicitly tell it to use something else, so I'll make it a hard dependency. This doesn't appear to present a bootstrapping issue.

Comment 2 Paul Howarth 2021-05-03 13:07:02 UTC
Build done:
https://koji.fedoraproject.org/koji/taskinfo?taskID=67142922