Bug 1956303

Summary: missing kernel-header for 5.11.17
Product: [Fedora] Fedora Reporter: Chung <cchung>
Component: kernel-headersAssignee: Justin M. Forbes <jforbes>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 32CC: acaringi, jeremy, jforbes, lgoncalv, pbrobinson, ptalbert
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-05-03 17:28:26 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Chung 2021-05-03 12:46:58 UTC
Description of problem:

kernel-header for 5.11.17 is missing.  This causing problem with install krnel-debug-package


Version-Release number of selected component (if applicable):
5.11.17-100.fc32.x86_64 

How reproducible:


Steps to Reproduce:
1. make a latest Fedora32 system, that should be 5.11.17-100.fc32.x86_64

2. dnf list | grep ^kernel-header
kernel-headers.x86_64   5.11.16-100.fc32  @updates  

3. Since there is a miss match, installing kernel debug will fail with the following message:
Error! echo
Your kernel headers for kernel 5.11.17-100.fc32.x86_64+debug cannot be found at
/lib/modules/5.11.17-100.fc32.x86_64+debug/build or /lib/modules/5.11.17-100.fc32.x86_64+debug/source.
You can use the --kernelsourcedir option to tell DKMS where it's located.
 Done. 


Actual results:


Expected results:


Additional info:

Comment 1 Chung 2021-05-03 17:27:26 UTC
Sorry.  Looks like it is working now.  We can close this.  Sorry for the false alarm.