Bug 1956313

Summary: Console Devfile Import Dev Preview broken
Product: OpenShift Container Platform Reporter: Christoph Jerolimov <cjerolim>
Component: Dev ConsoleAssignee: Christoph Jerolimov <cjerolim>
Status: CLOSED ERRATA QA Contact: Debsmita Santra <dsantra>
Severity: high Docs Contact: Harsh Mishra <hmishra>
Priority: unspecified    
Version: 4.7CC: aos-bugs, dsantra, nmukherj
Target Milestone: ---   
Target Release: 4.7.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Previously, when importing a devfile, the `buildguidanceimage-placeholder` container that provides the configuration for environment variables, ports, and limits was ignored. As a result, new deployments had a second container which could not start because the placeholder image could not be fetched, and the user container was missing additional configurations. This release removes the `buildguidanceimage-placeholder` container from new deployments, and adds environment variables, ports, and limit configurations to the user container so that the devfile is imported correctly.
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-05-19 15:17:01 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1952214    
Bug Blocks:    

Description Christoph Jerolimov 2021-05-03 13:06:24 UTC
Clone of https://bugzilla.redhat.com/show_bug.cgi?id=1952214 to backport this to 4.7

Description of problem:
When I use the sample repository from the Devfile Import Form, the pod never comes up

Please see https://github.com/openshift/console/issues/8729

Comment 1 Christoph Jerolimov 2021-05-04 20:38:50 UTC
Update Jira

Comment 4 Debsmita Santra 2021-05-12 09:55:17 UTC
verified on 4.7.0-0.nightly-2021-05-12-004740

Comment 6 errata-xmlrpc 2021-05-19 15:17:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1550