Bug 1956366

Summary: [RHOSP 16.2][Backport] Fix for PowerFlex/vxflex volume type conversion
Product: Red Hat OpenStack Reporter: arkady kanevsky <arkady_kanevsky>
Component: openstack-cinderAssignee: Pablo Caruana <pcaruana>
Status: CLOSED DEFERRED QA Contact: Tzach Shefi <tshefi>
Severity: medium Docs Contact: Andy Stillman <astillma>
Priority: medium    
Version: 17.0 (Wallaby)CC: arkady_kanevsky, astillma, a.stripeikis, gael_rehault, gcharot, gfidente, Ivan.Pchelintsev, jeanpierre.roquesalane, kholtz, kurt_hey, ltoscano, mburns, morazi, pcaruana, pgrist, rajini.karthik, sam.wan, tshefi, vladislav.belogrudov
Target Milestone: betaKeywords: OtherQA, Triaged
Target Release: 16.2 (Train on RHEL 8.4)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1883326 Environment:
Last Closed: 2021-05-24 18:20:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1883326    
Bug Blocks: 1824852, 1861408    

Comment 2 arkady kanevsky 2021-05-03 14:37:44 UTC
Duplicate for RHOSP 16.2

Comment 4 arkady kanevsky 2021-05-10 18:41:40 UTC
https://review.opendev.org/c/openstack/cinder/+/754785 finally landed upstream.
Dell will backport it all the way to Train if upstream community will allow it.
Hope we can land it in GA so we can use it for re-cert.

Comment 5 Pablo Caruana 2021-05-13 15:39:35 UTC
+++ This bug was initially created as a clone of Bug #1883326 +++
Fix PowerFlex volume type conversion

Fix bug with PowerFlex storage-assisted volume migration when volume migration was performed without conversion of volume type in cases where it should have been converted to/from thin/thick provisioned.

Comment 6 arkady kanevsky 2021-05-17 14:08:50 UTC
Suggest we target this functionality to RHOSP-17 since volume retype is used for volume migration that is targeted for 17.0
Thus I suggest we close this BZ and target Bug #1883326 to 17.