Bug 1956429

Summary: NVMe devices missing bootindex property in v5.2
Product: [Fedora] Fedora Reporter: Jonathan Lebon <jlebon>
Component: qemuAssignee: Fedora Virtualization Maintainers <virt-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 34CC: berrange, cfergeau, crobinso, dustymabe, miabbott, ondrejj, pbonzini, philmd, rjones, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: qemu-5.2.0-7.fc34 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-05-24 01:01:32 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jonathan Lebon 2021-05-03 16:44:44 UTC
Description of problem:

Migrating coreos-assembler from f33 to f34, we're hitting:

> qemu-system-x86_64: -device nvme,drive=d1,serial=primary-disk,bootindex=1: Property 'nvme.bootindex' not found

And indeed in f34 (v5.2):

$ qemu-kvm -device nvme,help | grep bootindex
$

Whereas in f33 (v5.1):

$ qemu-kvm -device nvme,help | grep bootindex
  bootindex=<int32>

It looks fixed in rawhide (v6.0):

$ qemu-kvm -device nvme,help | grep bootindex
  bootindex=<int32>

Version-Release number of selected component (if applicable):

$ rpm -q qemu-kvm
qemu-kvm-5.2.0-5.fc34.1.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Try to use `bootindex` property on NVMe devices

Actual results:

> qemu-system-x86_64: -device nvme,drive=d1,serial=primary-disk,bootindex=1: Property 'nvme.bootindex' not found

Expected results:

Works

Additional info:

Looks like the post-v5.2 fix for this upstream was in https://git.qemu.org/?p=qemu.git;a=commit;h=498114b37bc99fddcfc24b92bff7f1323fb32672 so hopefully it's just a straightforward backport.

Comment 1 Philippe Mathieu-Daudé 2021-05-03 17:43:12 UTC
Yes, commit 498114b37bc ("hw/block/nvme: expose 'bootindex' property") is enough.

Comment 2 Fedora Update System 2021-05-19 23:25:58 UTC
FEDORA-2021-303ad002d2 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-303ad002d2

Comment 3 Fedora Update System 2021-05-21 01:35:34 UTC
FEDORA-2021-303ad002d2 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-303ad002d2`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-303ad002d2

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2021-05-24 01:01:32 UTC
FEDORA-2021-303ad002d2 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.