Bug 1956574

Summary: isoDownloadURL stays HTTPS after changing SERVE_HTTPS=false and setting assisted route http
Product: OpenShift Container Platform Reporter: Chad Crum <ccrum>
Component: assisted-installerAssignee: Flavio Percoco <fpercoco>
assisted-installer sub component: Deployment Operator QA Contact: Chad Crum <ccrum>
Status: CLOSED NOTABUG Docs Contact:
Severity: medium    
Priority: medium CC: alazar, aos-bugs, ccrum, fpercoco
Version: 4.8   
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: AI-Team-Platform KNI-EDGE-4.8
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-06-01 11:48:02 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Chad Crum 2021-05-04 00:44:15 UTC
Description of problem:
isoDownloadURL remains https:// after setting SERVE_HTTPS=False and changing the assisted service route to http (removing re-encrypt).


Version-Release number of selected component (if applicable):
        "  Operator Package Name: assisted-service-operator",
        "  Source Index Image: quay.io/ocpmetal/assisted-service-index:latest",
        "  Operator Bundle: quay.io/ocpmetal/assisted-service-operator-bundle:latest",
        "  Operator Bundle Version: 0.0.1 (latest identified)",
        "  Operator Bundle Image Digest: sha256:9c027842d4f608318dccda6d709bc021ad5aa92a27b44ad790866e159af0160e",
        "  Operator Bundle Image Digest Short: 9c027842d4f6",


How reproducible:
100%

Steps to Reproduce:
1. Deploy latest assisted service via assisted service operator
2. Set SERVE_HTTPS=False in assisted service deployment (Must scale back assisted-service-operator in order to retain the SERVE_HTTPS value [oc scale --replicas=0 deployment/assisted-service-operator])
3. Edit assisted-service route and remove
    tls:
      termination: reencrypt
which makes it http
4. Create an infraenv
5. Get the isoDownloadURL: from infraenv (oc describe infraenv ???)
6. Attempt to download the isoDownloadURL

Actual results:
- Fail as it begins with https
- Can change to http:// and download the image

Expected results:
- Image downloads as expected

Additional info:
The reason I set this high is that it is blocking testing efforts and I am not aware of a work around to accomplish ztp.

Comment 1 Chad Crum 2021-05-04 01:24:34 UTC
Lowering priority and removing the blocker flags from this as I found the work around - delete assisted service file store content and restart assisted service pod.

Leaving this open for tracking as clearing out the assisted service files and deleting the pod does not seem friendly. (I did not find another bug specifically for this).

Comment 2 Ronnie Lazar 2021-06-01 11:48:02 UTC
Closing as we are not serving ISOs from AI, but from Ironic