Bug 1956738

Summary: [Doc]: if a BSL is deleted but an older backup references, going to see error noise in the logs
Product: Migration Toolkit for Containers Reporter: Avital Pinnick <apinnick>
Component: DocumentationAssignee: Avital Pinnick <apinnick>
Status: CLOSED NEXTRELEASE QA Contact: Xin jiang <xjiang>
Severity: medium Docs Contact: Avital Pinnick <apinnick>
Priority: low    
Version: 1.4.0CC: dymurray, ernelson, xjiang
Target Milestone: ---   
Target Release: 1.5.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1929832 Environment:
Last Closed: 2021-06-03 11:14:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1929832    
Bug Blocks:    

Description Avital Pinnick 2021-05-04 10:33:28 UTC
Bug cloned for downstream docs.

+++ This bug was initially created as a clone of Bug #1929832 +++

Description of problem:
If a migration is performed and Backups are created that reference a BSL, and then that BSL is deleted and/or replaced by a new one, but the backups remain on the cluster (or are synced from the same s3 bucket), you will often see the following error in the logs as velero attempts to reconcile said Backup:

"Error checking repository for stale locks"... "error getting backup storage location: backupstoragelocation.velero.io \"my-bsl\" not found".

Often users may be troubleshooting a failed migration and will latch onto this error in the logs, because on the surface it appears to be significant, when actually it's a red herring and there is likely a different root problem at play.

We'd like to get this documented in the troubleshooting tips of the best practices, as we've often has this brought to us as a question.

Version-Release number of selected component (if applicable):
1.4.0

Comment 2 Xin jiang 2021-06-02 09:02:30 UTC
LGTM

Comment 3 Avital Pinnick 2021-06-03 11:14:44 UTC
Changes merged