This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes

Bug 195727

Summary: xend won't start after upgrade to 2122 and 2133 kernels
Product: [Fedora] Fedora Reporter: Josh Crowe <josh>
Component: xenAssignee: Xen Maintainance List <xen-maint>
Status: CLOSED DUPLICATE QA Contact: Brian Brock <bbrock>
Severity: high Docs Contact:
Priority: medium    
Version: 5CC: bstein, chris, katzj
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-06-20 10:42:22 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Josh Crowe 2006-06-16 16:22:38 EDT
Description of problem:
xend won't start after upgrading from FC5 2054 kernel to 2122 kernel and
subsequently to 2133 kernel.

Version-Release number of selected component (if applicable):
2.6.16-1.2122_FC5xen0
2.6.16-1.2133_FC5xen0
kernel-xen0-2.6.16-1.2122_FC5
kernel-xen0-devel-2.6.16-1.2122_FC5
kernel-xen0-devel-2.6.16-1.2133_FC5
xen-3.0.2-0.FC5.3
kernel-xen0-2.6.16-1.2133_FC5

How reproducible:
Always

Steps to Reproduce:
1. Install FC5 w/Xen on Athlon 64 Dual Core box
2. Verify xend starts normally. Run "xm list" to see Xen domain 0.
2. Update available packages, including kernel 2133.
3. Reboot
4. Start xend service and check xend.log. Run "xm list" and see failure to
connect to xend.

Actual results:
After upgrading to 2122 kernel and subsequently to 2133, xend process is not
running, xm cannot connect to xend, and when a start or restart of the xend
process is attempted from the shell prompt via /etc/init.d/xend, the script
simply hangs. Similar results occur when using the Service Configuration
utility. When starting xend directly, it fails without error. The xend-debug.log
file shows no messages. The xend.log file shows the following when an attempt is
made to start the process:

[2006-06-11 20:06:50 xend] INFO (SrvDaemon:285) Xend Daemon started
[2006-06-11 20:06:50 xend] INFO (SrvDaemon:289) Xend changeset: unavailable .
[2006-06-11 20:06:51 xend.XendDomainInfo] DEBUG (XendDomainInfo:201)
XendDomainInfo.recreate({'paused': 0, 'cpu_time': 25917222470L, 'ssidref': 0,
'handle': [0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0], 'shutdown_reason':
0, 'dying': 0, 'dom': 0, 'mem_kb': 1861360, 'maxmem_kb': 17179869180,
'max_vcpu_id': 1, 'crashed': 0, 'running': 1, 'shutdown': 0, 'online_vcpus': 2,
'blocked': 0})
[2006-06-11 20:06:51 xend.XendDomainInfo] INFO (XendDomainInfo:213) Recreating
domain 0, UUID 00000000-0000-0000-0000-000000000000.
[2006-06-11 20:06:51 xend.XendDomainInfo] WARNING (XendDomainInfo:235) No vm
path in store for existing domain 0
[2006-06-11 20:06:51 xend.XendDomainInfo] DEBUG (XendDomainInfo:673) Storing VM
details: {'ssidref': '0', 'uuid': '00000000-0000-0000-0000-000000000000',
'on_reboot': 'restart', 'on_poweroff': 'destroy', 'name': 'Domain-0', 'vcpus':
'2', 'vcpu_avail': '3', 'memory': '1818', 'on_crash': 'restart', 'maxmem': '1818'}
[2006-06-11 20:06:51 xend.XendDomainInfo] DEBUG (XendDomainInfo:698) Storing
domain details: {'cpu/0/availability': 'online', 'memory/target': '1861632',
'cpu/1/availability': 'online', 'name': 'Domain-0', 'console/limit': '1048576',
'vm': '/vm/00000000-0000-0000-0000-000000000000', 'domid': '0'}
[2006-06-11 20:06:51 xend] DEBUG (XendDomain:152) number of vcpus to use is 0
[2006-06-11 20:06:51 xend.XendDomainInfo] DEBUG (XendDomainInfo:882)
XendDomainInfo.handleShutdownWatch

When 'xm list' is run, the following output is returned:
Error: Error connecting to xend: No such file or directory.  Is xend running?

Expected results:
xend starts normally from the shell script in /etc/init.d/, the Service
Configuration utility, or when directly calling the xend process.

Additional info:
I wiped the hard drive and reinstalled FC5 again to verify symptoms. Problem
existed in 2122. Upgraded on 6/11 to 2133, with no change in symptoms. CPU is
dual-core Athlon 64 with 2GB memory.
Comment 1 Chris Foote 2006-06-20 04:27:47 EDT
Are you sure that you don't have selinux enabled ?

I was about to submit a bug report for the same xend hanging issue when I
checked out /var/log/messages and discovered errors:

Jun 20 17:49:18 xentest kernel: audit(1150791558.571:2): avc:  denied  { getattr
} for  pid=1985 comm="ifup-eth" name="arping" dev=dm-0 ino=7995419
scontext=system_u:system_r:xend_t:s0
tcontext=system_u:object_r:netutils_exec_t:s0 tclass=file
Jun 20 17:49:18 xentest kernel: audit(1150791558.615:3): avc:  denied  { getattr
} for  pid=1985 comm="ifup-eth" name="arping" dev=dm-0 ino=7995419
scontext=system_u:system_r:xend_t:s0
tcontext=system_u:object_r:netutils_exec_t:s0 tclass=file
Jun 20 17:49:18 xentest kernel: audit(1150791558.751:4): avc:  denied  { setattr
} for  pid=2053 comm="python" name="xend" dev=dm-0 ino=3080203
scontext=system_u:system_r:xend_t:s0 tcontext=user_u:object_r:var_run_t:s0
tclass=dir
Jun 20 17:49:20 xentest kernel: audit(1150791560.627:5): avc:  denied  { getattr
} for  pid=2025 comm="ifup-eth" name="arping" dev=dm-0 ino=7995419
scontext=system_u:system_r:xend_t:s0
tcontext=system_u:object_r:netutils_exec_t:s0 tclass=file
Jun 20 17:49:20 xentest kernel: audit(1150791560.627:6): avc:  denied  { getattr
} for  pid=2025 comm="ifup-eth" name="arping" dev=dm-0 ino=7995419
scontext=system_u:system_r:xend_t:s0
tcontext=system_u:object_r:netutils_exec_t:s0 tclass=file

I disabled selinux (editing /etc/sysconfig/selinux and rebooting) and
it works fine.  This machine has an Intel P4 CPU.
Comment 2 Josh Crowe 2006-06-20 10:42:22 EDT
Thanks, Chris-- Disabling selinux fixed this. Dup'ing it to 186158 for
selinux-policy component, which states that this is fixed in
selinux-policy-2.2.38-1.fc5, however my machine is running
selinux-policy-2.2.40-1.fc5. Will update that bug appropriately.

*** This bug has been marked as a duplicate of 186158 ***