Bug 1958959

Summary: unneeded CCO alert already covered by CVO
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: Cloud Credential OperatorAssignee: Joel Diaz <jdiaz>
Status: CLOSED ERRATA QA Contact: wang lin <lwan>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.7CC: arane, dgoodwin, lwan
Target Milestone: ---   
Target Release: 4.6.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Removed functionality
Doc Text:
The cluster-version operator is responsible for reporting if the cloud-credential-operator's deployment is unhealthy; no need for the cloud-credential-operator to handle this directly (resulting in doubling reporting if there's an issue).
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-06-08 13:54:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1948702    
Bug Blocks:    

Comment 2 wang lin 2021-05-27 09:17:48 UTC
Verified this bug using the built by cluster-bot with PR https://github.com/openshift/cloud-credential-operator/pull/337 merged.

$ oc get clusterversion
NAME      VERSION                                                  AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.ci.test-2021-05-27-080846-ci-ln-h79wt0k-latest   True        False         4m56s   Cluster version is 4.6.0-0.ci.test-2021-05-27-080846-ci-ln-h79wt0k-latest

1. Login to prometheus console, check CloudCredentialOperatorDown has remove from CloudCredentialOperator

2. Create an invalid cr request, check cco is degraded
$ oc get co cloud-credential
NAME               VERSION                                                  AVAILABLE   PROGRESSING   DEGRADED   SINCE
cloud-credential   4.6.0-0.ci.test-2021-05-27-080846-ci-ln-h79wt0k-latest   True        True          True       41m

3.check when cco down, cvo will fire the alerts
    {
      "labels": {
        "alertname": "ClusterOperatorDegraded",
        "condition": "Degraded",
        "endpoint": "metrics",
        "instance": "10.0.187.47:9099",
        "job": "cluster-version-operator",
        "name": "cloud-credential",
        "namespace": "openshift-cluster-version",
        "pod": "cluster-version-operator-5595c5fdd6-tbvst",
        "prometheus": "openshift-monitoring/k8s",
        "reason": "CredentialsFailing",
        "service": "cluster-version-operator",
        "severity": "critical"
      },
      "annotations": {
        "message": "Cluster operator cloud-credential has been degraded for 10 minutes. Operator is degraded because CredentialsFailing and cluster upgrades will be unstable."
      },
      "startsAt": "2021-05-27T09:09:59.213Z",
      "endsAt": "2021-05-27T09:18:29.213Z",
      "generatorURL": "https://prometheus-k8s-openshift-monitoring.apps.ci-ln-h79wt0k-d5d6b.origin-ci-int-aws.dev.rhcloud.com/graph?g0.expr=cluster_operator_conditions%7Bcondition%3D%22Degraded%22%2Cjob%3D%22cluster-version-operator%22%7D+%3D%3D+1&g0.tab=1",
      "status": {
        "state": "active",
        "silencedBy": [],
        "inhibitedBy": []
      },
      "receivers": [
        "Critical"
      ],
      "fingerprint": "7e911a8af46a627e"
    },
    {
      "labels": {
        "alertname": "ClusterOperatorDown",
        "endpoint": "metrics",
        "instance": "10.0.187.47:9099",
        "job": "cluster-version-operator",
        "name": "cloud-credential",
        "namespace": "openshift-cluster-version",
        "pod": "cluster-version-operator-5595c5fdd6-tbvst",
        "prometheus": "openshift-monitoring/k8s",
        "service": "cluster-version-operator",
        "severity": "critical",
        "version": "4.6.0-0.ci.test-2021-05-27-080846-ci-ln-h79wt0k-latest"
      },
      "annotations": {
        "message": "Cluster operator cloud-credential has not been available for 10 minutes. Operator may be down or disabled, cluster will not be kept up to date and upgrades will not be possible."
      },
      "startsAt": "2021-05-27T09:09:59.213Z",
      "endsAt": "2021-05-27T09:18:29.213Z",
      "generatorURL": "https://prometheus-k8s-openshift-monitoring.apps.ci-ln-h79wt0k-d5d6b.origin-ci-int-aws.dev.rhcloud.com/graph?g0.expr=cluster_operator_up%7Bjob%3D%22cluster-version-operator%22%7D+%3D%3D+0&g0.tab=1",
      "status": {
        "state": "active",
        "silencedBy": [],
        "inhibitedBy": []
      },
      "receivers": [
        "Critical"
      ],
      "fingerprint": "9e847827c26ec62a"
    },


##
the bug is pre-merge verified. After the PR gets merged, the bug will be moved to VERIFIED by the bot automatically or, if not working, by me manually.

Comment 8 errata-xmlrpc 2021-06-08 13:54:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.32 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:2157