Bug 1962285

Summary: driver-toolkit missing some release metadata
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: Special Resource OperatorAssignee: Zvonko Kosic <zkosic>
Status: CLOSED ERRATA QA Contact: Lena Horsley <lhorsley>
Severity: high Docs Contact:
Priority: high    
Version: 4.7CC: aos-bugs, dagray, lhorsley
Target Milestone: ---   
Target Release: 4.7.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-06-29 04:19:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1961656    
Bug Blocks: 1962286    

Comment 2 Lena Horsley 2021-06-10 18:04:14 UTC
Verified in build: 4.7.0-0.nightly-2021-06-09-233032 

1. Go to the OpenShift release nightly build page for the nightly build, click "Download the installer," and then click "release.txt."


2. Search for "driver-toolkit" and pull the corresponding image to your dev machine with the command:
podman pull --authfile /path/to/pullsecret <openshift_release_repo>/<corresponding_image_to_your_dev_machine>


3. Enter the following command from the terminal:
podman run <image_from_previous_step> cat /etc/driver-toolkit-release.json


=====================================
Output from the command in step #3:


{ "KERNEL_VERSION": "4.18.0-240.22.1.el8_3", "RT_KERNEL_VERSION": "4.18.0-240.22.1.rt7.77.el8_3", "RHEL_VERSION": "8.3" }

Comment 4 OpenShift Automated Release Tooling 2021-06-17 12:29:08 UTC
OpenShift engineering has decided to not ship Red Hat OpenShift Container Platform 4.7.17 due a regression https://bugzilla.redhat.com/show_bug.cgi?id=1973006. All the fixes which were part of 4.7.17 will be now part of 4.7.18 and planned to be available in candidate channel on June 23 2021 and in fast channel on June 28th.

Comment 8 errata-xmlrpc 2021-06-29 04:19:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.18 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:2502