Bug 1962971

Summary: glibc: ppc64le: scv ABI error handling fails to check IS_ERR_VALUE
Product: [Fedora] Fedora Reporter: Dmitry V. Levin <ldv>
Component: glibcAssignee: Carlos O'Donell <codonell>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: rawhideCC: acaringi, adscvr, airlied, alciregi, aoliva, arjun.is, bskeggs, codonell, dan, dj, esyr, extras-qa, fweimer, gduarte, hdegoede, jarodwilson, jeremy, jglisse, jonathan, josef, kernel-maint, law, lgoncalv, linville, masami256, mcermak, mchehab, mfabian, pfrankli, ptalbert, rth, sipoyare, steved, tulioqm
Target Milestone: ---Keywords: BetaBlocker
Target Release: ---   
Hardware: ppc64le   
OS: Linux   
Whiteboard:
Fixed In Version: glibc-2.33-14.fc34 glibc-2.33.9000-18.fc35 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1929836 Environment:
Last Closed: 2021-07-06 13:32:49 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1071880    
Bug Blocks: 1930252, 1963901    

Description Dmitry V. Levin 2021-05-20 22:54:06 UTC
+++ This bug was initially created as a clone of Bug #1929836 +++

The scv ABI introduced by glibc-2.32.9000-24 at 2021-01-08 has the following bug: RET_SCV macro (added by upstream commit glibc-2.33~117) treats any negative value returned by syscall via scv ABI as an error, but this is not correct.

Proposed fix was posted by Nicholas Piggin at
https://sourceware.org/pipermail/libc-alpha/2021-May/126534.html

This bug was found by strace test suite and it blocks strace updates in Fedora.

I hope the fix will be applied before strace is kicked out from Fedora due to ftbfs which is 19 weeks already.

Comment 1 Fedora Update System 2021-06-01 13:46:20 UTC
FEDORA-2021-abbb0d8a88 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-abbb0d8a88

Comment 2 Carlos O'Donell 2021-06-01 13:47:36 UTC
This fix is currently pending the Fedora Rawhide sync with the upstream development branch.

The fix is going into Fedora 34 with the next errata going through bodhi.

Comment 3 Fedora Update System 2021-06-02 01:41:09 UTC
FEDORA-2021-abbb0d8a88 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-abbb0d8a88`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-abbb0d8a88

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2021-06-03 01:01:07 UTC
FEDORA-2021-abbb0d8a88 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 5 Fedora Update System 2021-06-16 08:27:59 UTC
FEDORA-2021-9ce0f65a09 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.