Bug 1965935

Summary: createrepo_c: FTBFS in Fedora rawhide
Product: [Fedora] Fedora Reporter: Tomáš Hrnčiar <thrnciar>
Component: createrepo_cAssignee: amatej
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: amatej, dmach, jmracek, jrohel, mblaha, pkratoch, rpm-software-management, tmlcoch
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
URL: https://koschei.fedoraproject.org/package/createrepo_c
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-06-14 10:35:23 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1890881, 1927309    

Description Tomáš Hrnčiar 2021-05-31 07:57:54 UTC
Description of problem:
Package createrepo_c fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
0.16.2-2.fc34

Steps to Reproduce:
koji build --scratch f35 createrepo_c-0.16.2-2.fc34.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/createrepo_c

Comment 1 amatej 2021-05-31 12:21:35 UTC
This is caused by a regression in libxml2, it was also reported here: https://bugzilla.redhat.com/show_bug.cgi?id=1965662

The fix is on the way and it should work again with: libxml2-2.9.12-4

https://bodhi.fedoraproject.org/updates/FEDORA-2021-ead324701f
https://bodhi.fedoraproject.org/updates/FEDORA-2021-cc498ce3e0

Comment 2 Miro Hrončok 2021-06-04 20:15:10 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 3 Miro Hrončok 2021-06-07 22:59:38 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 4 Miro Hrončok 2021-06-14 10:35:23 UTC
This package was successfully rebuilt with Python 3.10.

If you need this bugzilla open for tracking purposes, sorry for the automatic closing: feel free to reopen it.