Bug 1966433
| Summary: | 'PvUsageAnalysisFailed' error is displayed in MigPlan CR if source namespace is mapped to different target namespace | ||
|---|---|---|---|
| Product: | Migration Toolkit for Containers | Reporter: | Sergio <sregidor> |
| Component: | General | Assignee: | Pranav Gaikwad <pgaikwad> |
| Status: | CLOSED ERRATA | QA Contact: | Xin jiang <xjiang> |
| Severity: | high | Docs Contact: | Avital Pinnick <apinnick> |
| Priority: | high | ||
| Version: | 1.5.0 | CC: | ernelson, rjohnson, whu, xjiang |
| Target Milestone: | --- | ||
| Target Release: | 1.5.0 | ||
| Hardware: | Unspecified | ||
| OS: | Unspecified | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | If docs needed, set a value | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2021-07-28 04:08:07 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
Verified using MTC 1.5.0
SOURCE CLUSTER: AWS OCP 3.11 (CONTROLLER + UI)
TARGET CLUSETR: AWS OCP 4.7
Operator:
registry.redhat.io/rhmtc/openshift-migration-rhel7-operator@sha256:c0375fa6ecff4d50c181fc3f31d66b6c13023fecb8bcef6899197ccd96c50a30
- name: MIG_CONTROLLER_REPO
value: openshift-migration-controller-rhel8@sha256
- name: MIG_CONTROLLER_TAG
value: 83f26020b731f78dc9e817186d3247ab46d7daedec62c808be3259ed571656aa
- name: MIG_UI_REPO
value: openshift-migration-ui-rhel8@sha256
- name: MIG_UI_TAG
value: 4e177e58e311ff2d9c37935308591df5680838255e35b138a696b065c03044f8
- name: VELERO_REPO
value: openshift-migration-velero-rhel8@sha256
- name: VELERO_TAG
value: e776a798ce8c1b1e6fcc10edaded1e70514a5c6cc2c177dead2d82ef562becde
Now this warning is not displayed when the namespace is mapped to another name.
We move the status to VERIFIED.
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory (Migration Toolkit for Containers (MTC) image release advisory 1.5.0), and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHEA-2021:2929 |
Description of problem: When we have a namespace with a PVC attached to a pod and we create a migration plan for this namespace. If the migration plan maps the namespace to another name in the target cluster, a wrong PvUsageAnalysisFailed warning is displayed in the migplan. Version-Release number of selected component (if applicable): MTC 1.5.0 TARGET CLUSTER: OCP 4.8 AWS (gp2) SOURCE CLUSTER: OCP 3.11 AWS (gp2) REPLICATION REPOSITORY: AWS S3 How reproducible: Always Steps to Reproduce: 1. Deploy a sample django application $ oc new-project bz-test $ oc new-app django-psql-persistent 2. Create a migration plan for this namespace and map the namespace to another name. "bz-test-mapped" for instance Actual results: The migration plan will become ready, but it will display a PvUsageAnalysisFailed warning - category: Warn lastTransitionTime: "2021-05-31T14:43:45Z" message: 'Failed to compute PV resizing data for the following volumes. PV resizing will be disabled for these volumes and the migration may fail if the volumes are full or their requested and actual capacities differ in the source cluster. Please ensure that the volumes are attached to one or more running Pods for PV resizing to work correctly: [pvc-69a1dd43-c21c-11eb-a9dd-0eeaed03c931]' reason: NotDone status: "True" type: PvUsageAnalysisFailed Expected results: The pvc is properly attached, so this warning should not be displayed. Additional info: