Bug 1966508

Summary: OLM: v1beta1 CRDs
Product: OpenShift Container Platform Reporter: Stefan Schimanski <sttts>
Component: OLMAssignee: Kevin Rizza <krizza>
OLM sub component: OLM QA Contact: Jian Zhang <jiazha>
Status: CLOSED DUPLICATE Docs Contact:
Severity: high    
Priority: high CC: alegrand, anpicker, aos-bugs, davegord, erooth, hongyli, jiazha, juzhao, kakkoyun, kewang, krizza, lcosic, mfojtik, pknezevi, pkrupa, scolange, surbania, xxia
Version: 4.8Keywords: Reopened
Target Milestone: ---   
Target Release: 4.8.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1947794 Environment:
Last Closed: 2021-06-01 15:32:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1947719    

Comment 1 Stefan Schimanski 2021-06-01 10:14:55 UTC
Looks like this is due to one of

- advanced-cluster-management.test-rmwfj-ns.yaml
- couchbase-enterprise.test-rqfzf.yaml
- portworx-essentials.openshift-operators.yaml

that are installed in console-operator e2e tests.

Comment 2 Stefan Schimanski 2021-06-01 11:28:41 UTC
Not only in ci/prow/e2e-aws-operator (see above), but also in the normal e2e-gcp/aws jobs v1beta1 CRDs show up, this time:

cat *audit* | grep system:serviceaccount:openshift-operator-lifecycle-manager:olm-operator-serviceaccount | grep apiextensions.k8s.io/v1beta1 | jq .requestURI | sort | uniq
"/apis/apiextensions.k8s.io/v1beta1/customresourcedefinitions"
"/apis/apiextensions.k8s.io/v1beta1/customresourcedefinitions/kafkabridges.kafka.strimzi.io"
"/apis/apiextensions.k8s.io/v1beta1/customresourcedefinitions/kafkaconnectors.kafka.strimzi.io"
"/apis/apiextensions.k8s.io/v1beta1/customresourcedefinitions/kafkaconnects.kafka.strimzi.io"
"/apis/apiextensions.k8s.io/v1beta1/customresourcedefinitions/kafkaconnects2is.kafka.strimzi.io"
"/apis/apiextensions.k8s.io/v1beta1/customresourcedefinitions/kafkamirrormaker2s.kafka.strimzi.io"
"/apis/apiextensions.k8s.io/v1beta1/customresourcedefinitions/kafkamirrormakers.kafka.strimzi.io"
"/apis/apiextensions.k8s.io/v1beta1/customresourcedefinitions/kafkarebalances.kafka.strimzi.io"
"/apis/apiextensions.k8s.io/v1beta1/customresourcedefinitions/kafkas.kafka.strimzi.io"
"/apis/apiextensions.k8s.io/v1beta1/customresourcedefinitions/kafkatopics.kafka.strimzi.io"
"/apis/apiextensions.k8s.io/v1beta1/customresourcedefinitions/kafkausers.kafka.strimzi.io"

Comment 3 Kevin Rizza 2021-06-01 15:32:50 UTC
This is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1958296

OLM is explicitly aware of and still needs to write these deprecated APIs in 4.8 in order to give optional operators a way to migrate to the v1 versions of these APIs. We (OLM) are going to explicitly subsume this warning as part of the work we are doing for the above bugzilla.

*** This bug has been marked as a duplicate of bug 1958296 ***