Bug 1969105

Summary: IP address in Pods list table are showing node IP other than pod IP
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: Management ConsoleAssignee: Yadan Pei <yapei>
Status: CLOSED ERRATA QA Contact: Yadan Pei <yapei>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.8CC: aos-bugs, jhadvig, jokerman, spadgett, yanpzhan, yapei
Target Milestone: ---   
Target Release: 4.7.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-06-29 04:19:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1966487    
Bug Blocks:    

Description OpenShift BugZilla Robot 2021-06-07 23:44:20 UTC
+++ This bug was initially created as a clone of Bug #1966487 +++

Description of problem:
IP address column is showing node IP wrongly


Version-Release number of selected component (if applicable):
4.8.0-0.nightly-2021-05-31-190546

How reproducible:
Always

Steps to Reproduce:
1. goes to Pods list page /k8s/all-namespaces/pods, manage columns and show IP address
2.
3.

Actual results:
1. IP address column is showing Node IP, not pod IP

Expected results:
1. IP address should show pod IP

Additional info:

Comment 3 Yadan Pei 2021-06-15 02:19:02 UTC
Confirmed that the issue is fixed on OCP 4.7.17 nightly build 4.7.0-0.nightly-2021-06-12-151209

Comment 4 OpenShift Automated Release Tooling 2021-06-17 12:29:08 UTC
OpenShift engineering has decided to not ship Red Hat OpenShift Container Platform 4.7.17 due a regression https://bugzilla.redhat.com/show_bug.cgi?id=1973006. All the fixes which were part of 4.7.17 will be now part of 4.7.18 and planned to be available in candidate channel on June 23 2021 and in fast channel on June 28th.

Comment 8 errata-xmlrpc 2021-06-29 04:19:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.18 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:2502