Bug 1970796

Summary: Cluster local doesn't work for knative services created from dev console
Product: OpenShift Container Platform Reporter: Jaivardhan Kumar <jakumar>
Component: Dev ConsoleAssignee: Jaivardhan Kumar <jakumar>
Status: CLOSED ERRATA QA Contact: Mohammed Saud <msaud>
Severity: medium Docs Contact: Harsh Mishra <hmishra>
Priority: high    
Version: 4.7CC: aos-bugs, cjerolim, gamore, msaud, nmukherj
Target Milestone: ---   
Target Release: 4.7.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Previously, users were not able to create a Knative service as a private service from the *Developer* perspective. This issue has now been fixed, by updating the label `'networking.knative.dev/visibility': 'cluster-local'`.
Story Points: ---
Clone Of: 1969951 Environment:
Last Closed: 2021-06-29 04:20:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1969951    
Bug Blocks: 1978159    

Comment 2 Mohammed Saud 2021-06-18 06:19:32 UTC
Verified on:
Build:   4.7.0-0.nightly-2021-06-17-224843
Browser: Firefox 89

KSVC has the correct label.

Comment 5 errata-xmlrpc 2021-06-29 04:20:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.18 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:2502