Bug 1972412

Summary: SELinux is preventing mdadm from 'getattr' accesses on the directory /dev/dma_heap.
Product: [Fedora] Fedora Reporter: Carlos Mogas da Silva <r3pek>
Component: selinux-policyAssignee: Zdenek Pytela <zpytela>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 34CC: dwalsh, grepl.miroslav, lvrabec, mmalik, omosnace, vmojzis, zpytela
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:9c0e10777f3e914da536f083ad79df80361a6d0da1fd16e168243a092be01311;
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-06-15 20:53:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Carlos Mogas da Silva 2021-06-15 20:15:56 UTC
Description of problem:
Happens on boot
SELinux is preventing mdadm from 'getattr' accesses on the directory /dev/dma_heap.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that mdadm should be allowed getattr access on the dma_heap directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'mdadm' --raw | audit2allow -M my-mdadm
# semodule -X 300 -i my-mdadm.pp

Additional Information:
Source Context                system_u:system_r:mdadm_t:s0
Target Context                system_u:object_r:dma_device_dir_t:s0
Target Objects                /dev/dma_heap [ dir ]
Source                        mdadm
Source Path                   mdadm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
SELinux Policy RPM            selinux-policy-targeted-34.11-1.fc34.noarch
Local Policy RPM              selinux-policy-targeted-34.11-1.fc34.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.12.9-300.fc34.x86_64 #1 SMP Thu
                              Jun 3 13:51:40 UTC 2021 x86_64 x86_64
Alert Count                   1
First Seen                    2021-06-15 21:11:20 WEST
Last Seen                     2021-06-15 21:11:20 WEST
Local ID                      e74fdf32-59d3-4798-9d4c-5b4d2a37ce4a

Raw Audit Messages
type=AVC msg=audit(1623787880.861:148): avc:  denied  { getattr } for  pid=1011 comm="mdadm" path="/dev/dma_heap" dev="devtmpfs" ino=149 scontext=system_u:system_r:mdadm_t:s0 tcontext=system_u:object_r:dma_device_dir_t:s0 tclass=dir permissive=0


Hash: mdadm,mdadm_t,dma_device_dir_t,dir,getattr

Version-Release number of selected component:
selinux-policy-targeted-34.11-1.fc34.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.15.2
hashmarkername: setroubleshoot
kernel:         5.12.9-300.fc34.x86_64
type:           libreport

Comment 1 Zdenek Pytela 2021-06-15 20:53:19 UTC

*** This bug has been marked as a duplicate of bug 1970744 ***