Bug 1973

Summary: cant instal glib-1.2.1 from rpm
Product: [Retired] Red Hat Linux Reporter: pavon
Component: rpmAssignee: David Lawrence <dkl>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-04-04 16:48:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description pavon 1999-04-04 00:56:00 UTC
I'm trying to upgrade to glib-1.2.1(and gtk1.2) from
glib-1.01 that came with RH51. When i try to install the
glib-1.2.1-1.i386.rpm it keeps telling me that i need
libc.so.6 from glibc 2.0. But i have glib 2.0.7, and i can
see libc.so.6 in my /usr/lib directory! I tried forcing it
to install but everything broke when i did that so i
uninstalled it.

Comment 1 Jeff Johnson 1999-04-04 16:48:59 UTC
You are trying to install glibc-2.1 binaries on a glibc-2.0
machine. You will need to rebuild from the src.rpm.

To do this, download glib-1.2.1-1.src.rpm and type
	rpm --rebuilddb glib-1.2.1-1.src.rpm