This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 197421

Summary: Missing nfs-utils dependecy appears although nfs-utils is excluded in yum arguments
Product: [Fedora] Fedora Reporter: Kam Leo <a1tmblwd>
Component: nfs-utilsAssignee: Steve Dickson <steved>
Status: CLOSED RAWHIDE QA Contact: Ben Levenson <benl>
Severity: medium Docs Contact:
Priority: medium    
Version: 5CC: alexl, bugzilla.redhat.com, sonarguy, tomri
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-07-22 08:40:40 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 197437    
Bug Blocks:    

Description Kam Leo 2006-07-01 02:43:44 EDT
Description of problem:

nfs-utils dependecy appears although following command is used:

 yum --exclude=nfs-utils upgrade


Version-Release number of selected component (if applicable):

yum-2.6.1-0.fc5

How reproducible:

Always

Steps to Reproduce:
1.  Run yum upgrade and got error regarding missing dependency for nfs-utils

2.  Exclude nfs-utils from package list
  
Actual results:
yum --exclude=nfs-utils upgrade
Loading "installonlyn" plugin
Setting up Upgrade Process
Setting up repositories
dries                                                                [1/7]
livna                                                                [2/7]
macromedia                                                           [3/7]
updates                                                              [4/7]
core                                                                 [5/7]
freshrpms                                                            [6/7]
extras                                                               [7/7]
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package httpd-manual.i386 0:2.2.2-1.0 set to be updated
---> Downloading header for mplayerplug-in to pack into transaction set.
mplayerplug-in-3.25-1.lvn 100% |=========================|  10 kB    00:00
---> Package mplayerplug-in.i386 0:3.25-1.lvn5 set to be updated
---> Package libgssapi.i386 0:0.9-1.FC5 set to be updated
---> Package mod_ssl.i386 1:2.2.2-1.0 set to be updated
---> Package gnupg.i386 0:1.4.4-2 set to be updated
---> Package httpd.i386 0:2.2.2-1.0 set to be updated
---> Package xorg-x11-server-Xorg.i386 0:1.0.1-9.fc5.5 set to be updated
---> Package nfs-utils-lib.i386 0:1.0.8-4.FC5 set to be updated
--> Running transaction check
--> Processing Dependency: librpcsecgss.so.1 for package: nfs-utils
--> Processing Dependency: libgssapi.so.1 for package: nfs-utils
--> Finished Dependency Resolution
Error: Missing Dependency: librpcsecgss.so.1 is needed by package nfs-utils
Error: Missing Dependency: libgssapi.so.1 is needed by package nfs-utils

Expected results:

Yum ignore nfs-utils and upgrade other packages.

Additional info:

yum clean all|packages|cache has not effect. Wild card for nfs-utils has no effect.
Comment 1 Kam Leo 2006-07-01 02:47:59 EDT
"yum --exclude=nfs-utils-lib upgrade". "yum --exclude=nfs-utils-lib.i386
upgrade", and "yum --exclude=nfs-\* upgrade" also display same missing
dependency error. 
Comment 2 Penelope Fudd 2006-07-01 16:51:00 EDT
This popped up last night (2006-07-01):

/etc/cron.daily/yum.cron:
Error: Missing Dependency: librpcsecgss.so.1 is needed by package nfs-utils
Error: Missing Dependency: libgssapi.so.1 is needed by package netatalk
Error: Missing Dependency: libgssapi.so.1 is needed by package nfs-utils

This is just the generic cron-powered 'yum -y update', no exclusions.

It looks like the procedure for adding stuff to the update repository needs
work, as these update errors are happening a lot.
Comment 3 Penelope Fudd 2006-07-01 16:53:46 EDT
I guess the update is trying to remove older versions of these libraries, but
the already-installed nfs-utils and netatalk packages still require them.  Try
'rpm -e nfs-utils' and 'rpm -e netatalk'.  This will get rid of those two
packages, and the update should proceed, so don't remove them if you need them.
Comment 4 Scott Glaser 2006-07-01 22:25:16 EDT
Temp work around is to:

yum update --exclude=nfs-utils --exclude=nfs-utils-libs
Comment 5 Scott Glaser 2006-07-01 23:43:26 EDT
Sorry work around was incorrect it should be:

yum update --exclude=nfs-utils* --exclude=libgssapi*
Comment 6 Alex Lancaster 2006-07-02 02:22:09 EDT
Please fix this ASAP.  I expect these kinds of version skew problems between
Core and Extras (because of the separate build systems), but this is within Core
and should have been picked up straight away.
Comment 7 Nicholas Miell 2006-07-02 02:42:02 EDT
Correct workaround is:

yum install yum-utils
yumdownloader nfs-utils-1.0.8-1.FC5 nfs-utils-lib libgssapi
rpm -Uvh --oldpackage nfs-utils* libgssapi*

and then pass --exclude=nfs-utils to all yum invocations until a new version of
nfs-utils is released that RPM thinks is newer than the
nfs-utils-1.0.8.rc2-5.FC5 release.
Comment 8 Jeremy Katz 2006-07-03 23:21:57 EDT
*** Bug 197432 has been marked as a duplicate of this bug. ***
Comment 9 Kam Leo 2006-07-04 02:05:01 EDT
Fedora QA please explain why the component is changed to "nfs-utils" when the
problem is that the "EXCLUDE" switch for yum is not excluding nfs-utils or its
variants. 
Comment 10 Jeremy Katz 2006-07-05 08:57:06 EDT
Because nfs-utils *IS* being excluded.  But there's an update to libgssapi which
changes the soname; doing that update then breaks the installed nfs-utils.
Comment 11 P Fudd 2006-07-05 11:49:17 EDT
It also breaks the installed netatalk, which hasn't been addressed yet.
Comment 12 Alex Lancaster 2006-07-05 15:55:03 EDT
(In reply to comment #11)
> It also breaks the installed netatalk, which hasn't been addressed yet.

Does this mean a new build of netatalk, or does nfs-utils need to be rebuilt to
fix this?
Comment 13 Alex Lancaster 2006-07-05 15:58:23 EDT
(In reply to comment #12)

> Does this mean a new build of netatalk, or does nfs-utils need to be rebuilt to
> fix this?

Looks like bug #197437 should fix this.
Comment 14 Kam Leo 2006-07-05 17:32:48 EDT
(In reply to comment #10)
> Because nfs-utils *IS* being excluded.  But there's an update to libgssapi which
> changes the soname; doing that update then breaks the installed nfs-utils.

Thanks for the reply. It would have saved me some of the confusion if the
version of libgssapi.so to be installed and the version required for the
dependency were displayed. Any chance that yum will be enhanced with that
feature in the future?