Bug 1976302

Summary: Requirements for nvidia GPU driver container for driver toolkit
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: Special Resource OperatorAssignee: Zvonko Kosic <zkosic>
Status: CLOSED ERRATA QA Contact: Lena Horsley <lhorsley>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 4.7CC: aos-bugs, dagray, lhorsley, wabouham, zkosic
Target Milestone: ---   
Target Release: 4.7.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-07-26 17:35:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1974447    
Bug Blocks: 1978008    

Comment 3 Lena Horsley 2021-07-06 18:40:11 UTC
Verified in build: 4.7.0-0.nightly-2021-07-06-050841

1. Go to the OpenShift release nightly build page for the nightly build, click "Download the installer," and then click "release.txt."


2. Search for "driver-toolkit" and pull the corresponding image to your dev machine with the command:
podman pull --authfile /path/to/pullsecret <openshift_release_repo>/<corresponding_image_to_your_dev_machine>


3. Enter the following command from the terminal:
podman run <image_from_previous_step> dnf list installed | grep <string>


=====================================
Output from the command in step #3:

>>> gcc
gcc.x86_64                                    8.4.1-1.el8                          @rhel-8-appstream-rpms-x86_64
libgcc.x86_64                                 8.4.1-1.el8                          @rhel-8-baseos-rpms-x86_64

Comment 5 Siddharth Sharma 2021-07-09 21:07:56 UTC
OCP engineering has decided to not ship 4.7.20 due to a blocker. This bug will be shipped as part of next z-stream release 4.7.21 planned on July 27th

Comment 8 errata-xmlrpc 2021-07-26 17:35:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.21 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:2762