Bug 1981939

Summary: openshift/builder base images inconsistent with ART
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: BuildAssignee: Adam Kaplan <adam.kaplan>
Status: CLOSED ERRATA QA Contact: Jitendar Singh <jitsingh>
Severity: low Docs Contact:
Priority: low    
Version: 4.8CC: aos-bugs, gmontero
Target Milestone: ---   
Target Release: 4.8.z   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-08-03 06:09:58 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1981936    
Bug Blocks:    

Description OpenShift BugZilla Robot 2021-07-13 18:27:26 UTC
+++ This bug was initially created as a clone of Bug #1981936 +++

The Dockerfile for for openshift/builder is out of sync with what is specified in ART.

--- Additional comment from adam.kaplan on 2021-07-13 18:26:16 UTC ---

@Jitendar this can probably be moved directly to Verified. The change to the Dockerfile reflects what has already been done by ART downstream.

Comment 1 Gabe Montero 2021-07-21 15:45:28 UTC
Manually associating the PR and moving to post while we are still in the 4.8.0 vs. 4.8.z intermittent state as 4.8 has not quite GA'ed, but we know we want this in 4.8.z vs. 4.8.0.

If you do a bugzilla refresh in the PR you get:

expected the bug to target the "4.8.0" release, but it targets "4.8.z" instead


With the bug in POST, it helps those on bug watcher duty know there is a PR up for this.

Comment 4 Jitendar Singh 2021-07-28 12:05:38 UTC
verified
==============
From the 4.8.3 image build log, https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=1673124 
it used registry-proxy.engineering.redhat.com/rh-osbs/openshift-golang-builder:rhel_8_golang_1.16’

Comment 6 errata-xmlrpc 2021-08-03 06:09:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.3 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:2896