Bug 1982004

Summary: [4.6.z] On a Azure IPI installation MCO fails to create new nodes
Product: OpenShift Container Platform Reporter: Benjamin Gilbert <bgilbert>
Component: RHCOSAssignee: Benjamin Gilbert <bgilbert>
Status: CLOSED ERRATA QA Contact: Michael Nguyen <mnguyen>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.7CC: bgilbert, dornelas, jligon, mnguyen, mrussell, nstielau, smilner, vmedina
Target Milestone: ---   
Target Release: 4.6.z   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1982003 Environment:
Last Closed: 2021-10-13 07:30:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1964751, 1964753, 1980679, 1982001, 1982002, 1982003    
Bug Blocks:    

Comment 2 Benjamin Gilbert 2021-07-16 20:11:46 UTC
Fix landed in Git.  Awaiting bootimage bump.

Comment 3 RHCOS Bug Bot 2021-10-04 15:59:41 UTC
The fix for this bug has landed in a bootimage bump, as tracked in bug 1964751 (now in status MODIFIED).  Moving this bug to MODIFIED.

Comment 5 Michael Nguyen 2021-10-05 15:17:50 UTC
Verified on 4.6.0-0.nightly-2021-10-04-202943.  afterburn checkin service runs after ignition fetch

$ oc get nodes
$ oc debug node/ci-ln-03nx4fb-002ac-dbkln-worker-centralus1-6kg4h
Starting pod/ci-ln-03nx4fb-002ac-dbkln-worker-centralus1-6kg4h-debug ...
To use host binaries, run `chroot /host`
If you don't see a command prompt, try pressing enter.
sh-4.2# chroot /host
sh-4.4# grep ^After /usr/lib/dracut/modules.d/30rhcos-afterburn-checkin/rhcos-afterburn-checkin.service
After=ignition-fetch.service
sh-4.4#  journalctl -u ignition-fetch | grep -i start; journalctl | grep coreos-kargs-reboot; journalctl -u hcos-afterburn-checkin | grep -i start
Oct 05 14:21:56 localhost systemd[1]: Starting Ignition (fetch)...
Oct 05 14:21:57 localhost ignition[764]: op(1): [started]  mounting "/dev/disk/by-id/ata-Virtual_CD" at "/tmp/ignition-azure370071335"
Oct 05 14:21:57 localhost ignition[764]: op(2): [started]  unmounting "/dev/disk/by-id/ata-Virtual_CD" at "/tmp/ignition-azure370071335"
Oct 05 14:22:03 localhost systemd[1]: Started Ignition (fetch).
Oct 05 14:22:03 localhost systemd[1]: Starting Afterburn (Check In - from the initramfs)...
Oct 05 14:22:32 localhost systemd[1]: Started Afterburn (Check In - from the initramfs).
sh-4.4# rpm-ostree status
State: idle
Deployments:
* pivot://quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:ec807fd1893cd3e5a26b396e0d6e7fa043fad53d056d0b5a247f4160ae2b183c
              CustomOrigin: Managed by machine-config-operator
                   Version: 46.82.202109281556-0 (2021-09-28T15:59:50Z)

  ostree://f85d8febca4775c5a0a59defdac14b06e80dcdb2e5bfe03d30b4d1f2bd35805e
                   Version: 46.82.202109242004-0 (2021-09-24T20:07:59Z)

Comment 8 errata-xmlrpc 2021-10-13 07:30:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.47 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3737