Bug 1990001

Summary: kicad: FTBFS in Fedora rawhide
Product: [Fedora] Fedora Reporter: Tomáš Hrnčiar <thrnciar>
Component: kicadAssignee: Steven A. Falco <stevenfalco>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: aimylios, alain.vigne.14, gmarr, kiarakovalevsky, stevenfalco, thibault
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
URL: https://koschei.fedoraproject.org/package/kicad
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-08-04 15:21:53 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1927309, 1890881    

Description Tomáš Hrnčiar 2021-08-04 14:24:28 UTC
Description of problem:
Package kicad fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
5.1.10-5.fc35

Steps to Reproduce:
koji build --scratch f35 kicad-5.1.10-5.fc35.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/kicad

Comment 1 Steven A. Falco 2021-08-04 15:21:53 UTC
This FTBFS is due to python-wxpython4 being broken, as described in bug 1988466.  The python-wxpython4 problem likely affects all projects that require it.

Bug 1988466 has now been resolved, and that allows kicad to build properly.