Bug 1990113

Summary: Multus whereabouts assigns duplicate IP addresses to pods when have large number of replicas
Product: OpenShift Container Platform Reporter: Douglas Smith <dosmith>
Component: NetworkingAssignee: Douglas Smith <dosmith>
Networking sub component: multus QA Contact: Ying Wang <yingwang>
Status: CLOSED ERRATA Docs Contact:
Severity: urgent    
Priority: high CC: aapark, anbhat, dosmith, ealcaniz, eminguez, pibanezr, tohayash, weliang, xingli, zzhao
Version: 4.7Keywords: FastFix
Target Milestone: ---   
Target Release: 4.8.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: Telco:Networking
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1965268
: 1990115 (view as bug list) Environment:
Last Closed: 2021-09-21 08:02:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1990115    
Bug Blocks: 1965268    

Comment 1 Ying Wang 2021-09-08 10:25:50 UTC
Created ovn cluster on cluster-bot using openshift/whereabouts-cni#63 and openshift/cluster-network-operator#1185.
Created 200 pods and attached Multus whereabouts network, no duplicate ip was found.



% oc version
Client Version: 4.9.0-0.nightly-2021-08-18-144658
Server Version: 4.8.0-0.ci.test-2021-09-08-081226-ci-ln-ftrcfi2-latest
Kubernetes Version: v1.21.1-1398+98073871f173ba-dirty

Comment 3 Weibin Liang 2021-09-10 17:10:57 UTC
According to test result from comment 1, mark this bug to be verified

Comment 6 errata-xmlrpc 2021-09-21 08:02:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.12 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3511