Bug 1990627

Summary: OLM fails with 'ResolutionFailed' found multiple channel heads due to deprecated inner channel entry
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: OLMAssignee: Kevin Rizza <krizza>
OLM sub component: OLM QA Contact: Jian Zhang <jiazha>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: high CC: bluddy, jiazha, kliberti, krizza, rgopired, swoodman, tflannag
Version: 4.7Keywords: Reopened, Triaged
Target Milestone: ---   
Target Release: 4.6.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-09-09 01:52:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1989712    
Bug Blocks:    

Comment 4 Jian Zhang 2021-08-26 03:30:35 UTC
1, Install an OCP cluster that contains the fixed PR.
[cloud-user@preserve-olm-env jian]$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2021-08-25-190633   True        False         16m     Cluster version is 4.6.0-0.nightly-2021-08-25-190633
[cloud-user@preserve-olm-env jian]$ oc -n openshift-operator-lifecycle-manager exec deploy/catalog-operator -- olm --version
OLM version: 0.16.1
git commit: a6a6b9d756c5e74e2525d2987aaa8df07b8d55c8

2, Create a CatalogSource that consumes an index image that contains the AMQ Stream v1.6.2.
[cloud-user@preserve-olm-env jian]$ cat cs-amq.yaml 
apiVersion: operators.coreos.com/v1alpha1
kind: CatalogSource
metadata:
  name: amq-operators
  namespace: openshift-marketplace
spec:
  displayName: Jian Operators
  image: quay.io/olmqe/rh-index:amq
  priority: -100
  publisher: Jian
  sourceType: grpc
  updateStrategy:
    registryPoll:
      interval: 10m0s
[cloud-user@preserve-olm-env jian]$ oc create -f cs-amq.yaml 
catalogsource.operators.coreos.com/amq-operators created

[cloud-user@preserve-olm-env jian]$ oc get packagemanifest|grep Jian|grep amq
amq-broker                                           Jian Operators        44s
amq-online                                           Jian Operators        44s
amq-broker-rhel8                                     Jian Operators        44s
amq-streams                                          Jian Operators        44s
amq7-interconnect-operator                           Jian Operators        44s
amq-broker-lts                                       Jian Operators        44s

3, Subscribe to the amqstreams.v1.6.2.
[cloud-user@preserve-olm-env jian]$ cat sub-amq.yaml 
apiVersion: operators.coreos.com/v1alpha1
kind: Subscription
metadata:
  name: amq-streams
  namespace: openshift-operators
spec:
  channel: amq-streams-1.6.x
  installPlanApproval: Automatic
  name: amq-streams
  source: amq-operators
  sourceNamespace: openshift-marketplace
  startingCSV: amqstreams.v1.6.2
[cloud-user@preserve-olm-env jian]$ oc create -f sub-amq.yaml 
subscription.operators.coreos.com/amq-streams created
[cloud-user@preserve-olm-env jian]$ oc get sub
NAME          PACKAGE       SOURCE          CHANNEL
amq-streams   amq-streams   amq-operators   amq-streams-1.6.x
[cloud-user@preserve-olm-env jian]$ oc get ip
NAME            CSV                 APPROVAL    APPROVED
install-lpxqn   amqstreams.v1.6.2   Automatic   true
[cloud-user@preserve-olm-env jian]$ oc get csv
NAME                DISPLAY                             VERSION   REPLACES            PHASE
amqstreams.v1.6.2   Red Hat Integration - AMQ Streams   1.6.2     amqstreams.v1.6.1   Succeeded

4, Upgrade it to AMQ Streams v1.7.2 by switching the channel to `stable`. no `multiple channel heads` error was found. Verify it.
[cloud-user@preserve-olm-env jian]$ oc -n openshift-operator-lifecycle-manager logs catalog-operator-6d5cbf95c-x5fxl|grep "multiple channel heads"

Comment 7 errata-xmlrpc 2021-09-09 01:52:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.44 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3395