Bug 199486

Summary: xen depends on xen-devel
Product: [Fedora] Fedora Reporter: Mark McLoughlin <markmc>
Component: xenAssignee: Xen Maintainance List <xen-maint>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: bstein, katzj
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-07-19 16:54:08 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
xen-libxenstore.patch none

Description Mark McLoughlin 2006-07-19 16:10:16 EDT
unlike libxenctl and libxenguest, libxenstore is unversioned.

What this means is that xen-devel owns libxenstore.so and xen requires it, so
xen depends on xen-devel, which is obviously wrong.

Attached is a patch which moves libxenstore.so into xen-libs.

Sane enough to commit?

(Obviously, the correct fix is to actually make libxenstore.so versioned. I'll
push that upstream)
Comment 1 Mark McLoughlin 2006-07-19 16:10:16 EDT
Created attachment 132706 [details]
xen-libxenstore.patch
Comment 2 Jeremy Katz 2006-07-19 16:54:08 EDT
Applied and built