Bug 1995872

Summary: OpenShift SDN doesn't add NOTRACK rule to raw iptables table to prevent vxlan from reaching conntrack
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: NetworkingAssignee: Andrew Stoycos <astoycos>
Networking sub component: openshift-sdn QA Contact: Ying Wang <yingwang>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: high CC: andreajess2003, astoycos, jeharris, ktenzer, palonsor, rhowe, scuppett, snetting, surya, tmanor, williamsdanielusa, yingwang, zzhao
Version: 4.6Keywords: FastFix
Target Milestone: ---   
Target Release: 4.7.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-09-15 09:16:49 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1995871    
Bug Blocks: 1995873    

Comment 1 Ying Wang 2021-08-31 10:30:50 UTC
Deployed cluster via cluster-bot using openshift/sdn/pull/338, the issue is fixed.


sh-4.4# iptables -t raw -S
-P PREROUTING ACCEPT
-P OUTPUT ACCEPT
-N OPENSHIFT-NOTRACK
-A PREROUTING -m comment --comment "disable conntrack for vxlan" -j OPENSHIFT-NOTRACK
-A OUTPUT -m comment --comment "disable conntrack for vxlan" -j OPENSHIFT-NOTRACK
-A OPENSHIFT-NOTRACK -p udp -m udp --dport 4789 -j NOTRACK
sh-4.4# exit


% oc version
Client Version: 4.9.0-0.nightly-2021-08-18-144658
Server Version: 4.7.0-0.ci.test-2021-08-31-091530-ci-ln-s3w5yrb-latest
Kubernetes Version: v1.20.0-1095+9689d22dc3121e-dirty


Thanks,
Ying

Comment 2 Ying Wang 2021-08-31 10:31:43 UTC
Deployed cluster via cluster-bot using openshift/sdn/pull/338, the issue is fixed.


sh-4.4# iptables -t raw -S
-P PREROUTING ACCEPT
-P OUTPUT ACCEPT
-N OPENSHIFT-NOTRACK
-A PREROUTING -m comment --comment "disable conntrack for vxlan" -j OPENSHIFT-NOTRACK
-A OUTPUT -m comment --comment "disable conntrack for vxlan" -j OPENSHIFT-NOTRACK
-A OPENSHIFT-NOTRACK -p udp -m udp --dport 4789 -j NOTRACK
sh-4.4# exit


% oc version
Client Version: 4.9.0-0.nightly-2021-08-18-144658
Server Version: 4.7.0-0.ci.test-2021-08-31-091530-ci-ln-s3w5yrb-latest
Kubernetes Version: v1.20.0-1095+9689d22dc3121e-dirty


Thanks,
Ying

Comment 6 Ying Wang 2021-09-07 03:10:38 UTC
Checked on version 4.7.0-0.nightly-2021-09-06-042858, issue is fixed.


sh-4.4# iptables -t raw -S
-P PREROUTING ACCEPT
-P OUTPUT ACCEPT
-N OPENSHIFT-NOTRACK
-A PREROUTING -m comment --comment "disable conntrack for vxlan" -j OPENSHIFT-NOTRACK
-A OUTPUT -m comment --comment "disable conntrack for vxlan" -j OPENSHIFT-NOTRACK
-A OPENSHIFT-NOTRACK -p udp -m udp --dport 4789 -j NOTRACK


% oc version
Client Version: 4.9.0-0.nightly-2021-08-18-144658
Server Version: 4.7.0-0.nightly-2021-09-06-042858
Kubernetes Version: v1.20.0+9689d22


Thanks,
Ying

Comment 8 errata-xmlrpc 2021-09-15 09:16:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.30 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3422

Comment 9 Daniel Williams 2022-10-31 03:10:15 UTC
The information you share is very good and interesting I know more useful things. Keep posting interesting things and I will keep an eye on your posts. https://gettingoverit.co

Comment 10 jessica112 2023-02-25 02:53:22 UTC Comment hidden (spam)