Bug 1995873

Summary: OpenShift SDN doesn't add NOTRACK rule to raw iptables table to prevent vxlan from reaching conntrack
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: NetworkingAssignee: Andrew Stoycos <astoycos>
Networking sub component: openshift-sdn QA Contact: Ying Wang <yingwang>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: high CC: alchan, astoycos, jeharris, ktenzer, palonsor, rhowe, scuppett, snetting, surya, tmanor, yingwang, zzhao
Version: 4.6Keywords: FastFix
Target Milestone: ---   
Target Release: 4.6.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-09-22 20:06:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1995872    
Bug Blocks:    

Comment 3 Ying Wang 2021-09-08 15:09:02 UTC
created cluster on cluster-bot using openshift/sdn/pull/339, this issue is fixed.


sh-4.4# iptables -t raw -S
-P PREROUTING ACCEPT
-P OUTPUT ACCEPT
-N OPENSHIFT-NOTRACK
-A PREROUTING -m comment --comment "disable conntrack for vxlan" -j OPENSHIFT-NOTRACK
-A OUTPUT -m comment --comment "disable conntrack for vxlan" -j OPENSHIFT-NOTRACK
-A OPENSHIFT-NOTRACK -p udp -m udp --dport 4789 -j NOTRACK
sh-4.4# exit


%  oc version
Client Version: 4.9.0-0.nightly-2021-08-18-144658
Server Version: 4.6.0-0.ci.test-2021-09-08-134416-ci-ln-tdptys2-latest
Kubernetes Version: v1.19.2-1085+1cec8759126205-dirty

Comment 8 Ying Wang 2021-09-10 02:56:53 UTC
Checked on version 4.6.0-0.nightly-2021-09-09-165319, issue is fixed.


sh-4.4# iptables -t raw -S
-P PREROUTING ACCEPT
-P OUTPUT ACCEPT
-N OPENSHIFT-NOTRACK
-A PREROUTING -m comment --comment "disable conntrack for vxlan" -j OPENSHIFT-NOTRACK
-A OUTPUT -m comment --comment "disable conntrack for vxlan" -j OPENSHIFT-NOTRACK
-A OPENSHIFT-NOTRACK -p udp -m udp --dport 4789 -j NOTRACK


% oc version
Client Version: 4.9.0-0.nightly-2021-08-18-144658
Server Version: 4.6.0-0.nightly-2021-09-09-165319
Kubernetes Version: v1.19.0+1cec875

Comment 11 errata-xmlrpc 2021-09-22 20:06:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.45 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3517