Bug 1996417

Summary: F36FailsToInstall: golang-gocloud-devel
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: golang-gocloudAssignee: Robert-André Mauchin 🐧 <zebob.m>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: go-sig, zebob.m
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: golang-gocloud-0.24.0-1.fc35~bootstrap golang-gocloud-0.24.0-1.fc34~bootstrap golang-gocloud-0.24.0-1.fc39~bootstrap Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-09-21 11:35:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1992487    

Description Miro Hrončok 2021-08-22 17:40:54 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (golang-gocloud) Fails To Install in Fedora 36:

can't install golang-gocloud-devel:
  - nothing provides golang(go.etcd.io/etcd/clientv3) needed by golang-gocloud-devel-0.21.0-3.fc35~bootstrap.noarch
  - nothing provides golang(go.etcd.io/etcd/etcdserver/api/v3rpc/rpctypes) needed by golang-gocloud-devel-0.21.0-3.fc35~bootstrap.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2021-08-30 17:27:24 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 2 Miro Hrončok 2021-09-13 09:41:38 UTC
*** Bug 2003584 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2021-09-17 14:13:01 UTC
FEDORA-2021-5bce787ca6 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-5bce787ca6

Comment 4 Fedora Update System 2021-09-17 14:14:00 UTC
FEDORA-2021-5721144db1 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-5721144db1

Comment 5 Fedora Update System 2021-09-17 15:20:15 UTC
FEDORA-2021-5bce787ca6 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-5bce787ca6`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-5bce787ca6

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2021-09-17 19:41:47 UTC
FEDORA-2021-5721144db1 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-5721144db1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-5721144db1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Miro Hrončok 2021-09-21 11:35:10 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 36.

Thanks for taking care of it!

Comment 8 Fedora Update System 2021-09-24 20:27:03 UTC
FEDORA-2021-5721144db1 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2021-09-24 20:32:17 UTC
FEDORA-2021-5bce787ca6 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Fedora Update System 2023-07-23 06:41:31 UTC
FEDORA-2023-258737ee34 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-258737ee34

Comment 11 Fedora Update System 2023-07-23 06:42:04 UTC
FEDORA-2023-258737ee34 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.