Bug 2001641

Summary: Syntax error appears to breaks the ovn egressFirewall policy during the cluster upgrade
Product: OpenShift Container Platform Reporter: Riccardo Ravaioli <rravaiol>
Component: NetworkingAssignee: Riccardo Ravaioli <rravaiol>
Networking sub component: ovn-kubernetes QA Contact: huirwang
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: urgent CC: agawand, anbhat, anusaxen, arghosh, bbennett, huirwang, openshift-bugs-escalate, pratshar, rravaiol, rupatel, sberthol, skharat, zzhao
Version: 4.7   
Target Milestone: ---   
Target Release: 4.8.z   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1997438 Environment:
Last Closed: 2021-09-21 08:02:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1997438    
Bug Blocks: 2001998    

Comment 2 zhaozhanqi 2021-09-10 10:57:48 UTC
setup cluster with 4.7.11 version which default is local gateway and upgrade to 4.8 fixed version. it will upgrade to share gateways.  this issue can be veirified

However if we setup 4.7.29 version with local gateway config map specified before setup the cluster.  and then upgrade to 4.8 fixed version, the cluster still be local gateways, then there is another issue https://bugzilla.redhat.com/show_bug.cgi?id=2002958

Comment 8 errata-xmlrpc 2021-09-21 08:02:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.12 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3511