Bug 2001929 (CVE-2021-3770)

Summary: CVE-2021-3770 vim: using retab with large value may lead to heap buffer overflow
Product: [Other] Security Response Reporter: Marian Rehak <mrehak>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: fhrdina, gchamoul, karsten, saroy, zdohnal
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: vim 8.2.3403 Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in vim. A possible heap-based buffer overflow could allow an attacker to input a specially crafted file leading to a crash or code execution. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-05-17 14:45:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2001930, 2002318, 2002319, 2002320    
Bug Blocks: 2001931    

Description Marian Rehak 2021-09-07 13:31:05 UTC
Invalid memory access when using :retab with large value may lead to Heap-based Buffer Overflow.

Upstream reference:

https://github.com/vim/vim/commit/b7081e135a16091c93f6f5f7525a5c58fb7ca9f9

Comment 1 Marian Rehak 2021-09-07 13:31:20 UTC
Created vim tracking bugs for this issue:

Affects: fedora-all [bug 2001930]

Comment 2 juneau 2021-09-08 14:18:11 UTC
Marking openshift-hosted-osd3 notaffected.

Comment 10 Product Security DevOps Team 2022-05-17 14:45:09 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2021-3770