Bug 2004581

Summary: OVS logging in must gather is missing previous logging levels
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: NetworkingAssignee: Nadia Pinaeva <npinaeva>
Networking sub component: ovn-kubernetes QA Contact: Ross Brattain <rbrattai>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: high CC: aconstan, astoycos, npinaeva, rbrattai, surya
Version: 4.7   
Target Milestone: ---   
Target Release: 4.7.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-10-12 19:52:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 2004122    
Bug Blocks:    

Comment 3 Ross Brattain 2021-09-27 18:36:17 UTC
Verified on 4.7.0-0.nightly-2021-09-24-191646

ExecStartPost={ path=/usr/bin/ovs-appctl ; argv[]=/usr/bin/ovs-appctl vlog/set syslog:info ; ignore_errors=yes ; start_time=[Mon 2021-09-27 18:07:32 UTC] ; stop_time=[Mon 2021-09-27 18:07:32 UTC] ; pid=1150 ; code=exited ; status=0 }
ExecReload={ path=/usr/bin/ovs-appctl ; argv[]=/usr/bin/ovs-appctl vlog/set syslog:info ; ignore_errors=yes ; start_time=[n/a] ; stop_time=[n/a] ; pid=0 ; code=(null) ; status=0/0 }


Sep 27 18:05:20.029872 ip-10-0-243-49 systemd[1] Starting Open vSwitch Forwarding Unit...
Sep 27 18:05:20.157588 ip-10-0-243-49 ovs-ctl[1609] Inserting openvswitch module.
Sep 27 18:05:20.165664 ip-10-0-243-49 ovs-ctl[1609] 2021-09-27T18:05:20Z|00001|dns_resolve|WARN|Failed to read /etc/resolv.conf: No such file or directory
Sep 27 18:05:20.165660 ip-10-0-243-49 ovs-vswitchd[1653] ovs|00001|dns_resolve|WARN|Failed to read /etc/resolv.conf: No such file or directory
Sep 27 18:05:20.425781 ip-10-0-243-49 ovs-ctl[1609] Starting ovs-vswitchd.
Sep 27 18:05:20.432842 ip-10-0-243-49 ovs-ctl[1609] Enabling remote OVSDB managers.
Sep 27 18:05:20.432907 ip-10-0-243-49 ovs-vsctl[1662] ovs|00001|vsctl|INFO|Called as ovs-vsctl --no-wait add Open_vSwitch . external-ids hostname=ip-10-0-243-49
Sep 27 18:05:20.439607 ip-10-0-243-49 systemd[1] Started Open vSwitch Forwarding Unit.
Sep 27 18:06:37.666789 ip-10-0-243-49 ovs-vswitchd[1654] ovs|00009|memory|INFO|51404 kB peak resident set size after 77.5 seconds
Sep 27 18:06:37.718154 ip-10-0-243-49 systemd[1] Stopping Open vSwitch Forwarding Unit...
Sep 27 18:06:37.747907 ip-10-0-243-49 ovs-ctl[2149] Exiting ovs-vswitchd (1654).
Sep 27 18:06:37.849880 ip-10-0-243-49 systemd[1] ovs-vswitchd.service: Succeeded.
Sep 27 18:06:37.850582 ip-10-0-243-49 systemd[1] Stopped Open vSwitch Forwarding Unit.
Sep 27 18:06:37.852857 ip-10-0-243-49 systemd[1] ovs-vswitchd.service: Consumed 197ms CPU time
-- Logs begin at Mon 2021-09-27 18:04:53 UTC, end at Mon 2021-09-27 18:31:02 UTC. --
Sep 27 18:07:31.898865 localhost systemd[1] Starting Open vSwitch Forwarding Unit...
Sep 27 18:07:31.997585 localhost ovs-ctl[1100] Inserting openvswitch module.
Sep 27 18:07:32.095695 localhost ovs-ctl[1100] Starting ovs-vswitchd.
Sep 27 18:07:32.101384 localhost ovs-vsctl[1148] ovs|00001|vsctl|INFO|Called as ovs-vsctl --no-wait add Open_vSwitch . external-ids hostname=localhost
Sep 27 18:07:32.102530 localhost ovs-ctl[1100] Enabling remote OVSDB managers.
Sep 27 18:07:32.108686 localhost systemd[1] Started Open vSwitch Forwarding Unit.
Sep 27 18:07:34.553162 ip-10-0-243-49 ovs-vswitchd[1141] ovs|00008|ofproto_dpif|INFO|system@ovs-system: Datapath supports recirculation
Sep 27 18:07:34.553348 ip-10-0-243-49 ovs-vswitchd[1141] ovs|00009|ofproto_dpif|INFO|system@ovs-system: VLAN header stack length probed as 2
Sep 27 18:07:34.553457 ip-10-0-243-49 ovs-vswitchd[1141] ovs|00010|ofproto_dpif|INFO|system@ovs-system: MPLS label stack length probed as 3
Sep 27 18:07:34.553499 ip-10-0-243-49 ovs-vswitchd[1141] ovs|00011|ofproto_dpif|INFO|system@ovs-system: Datapath supports truncate action
Sep 27 18:07:34.553550 ip-10-0-243-49 ovs-vswitchd[1141] ovs|00012|ofproto_dpif|INFO|system@ovs-system: Datapath supports unique flow ids
Sep 27 18:07:34.553575 ip-10-0-243-49 ovs-vswitchd[1141] ovs|00013|ofproto_dpif|INFO|system@ovs-system: Datapath supports clone action
Sep 27 18:07:34.553810 ip-10-0-243-49 ovs-vswitchd[1141] ovs|00014|ofproto_dpif|INFO|system@ovs-system: Max sample nesting level probed as 10
Sep 27 18:07:34.553858 ip-10-0-243-49 ovs-vswitchd[1141] ovs|00015|ofproto_dpif|INFO|system@ovs-system: Datapath supports eventmask in conntrack action
Sep 27 18:07:34.553940 ip-10-0-243-49 ovs-vswitchd[1141] ovs|00016|ofproto_dpif|INFO|system@ovs-system: Datapath supports ct_clear action
Sep 27 18:07:34.553970 ip-10-0-243-49 ovs-vswitchd[1141] ovs|00017|ofproto_dpif|INFO|system@ovs-system: Max dp_hash algorithm probed to be 0

Comment 6 errata-xmlrpc 2021-10-12 19:52:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.33 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3686