Bug 2004677

Summary: [4.8] Boot option recovery menu prevents image boot
Product: OpenShift Container Platform Reporter: RHCOS Bug Bot <rhcos-bot>
Component: RHCOSAssignee: Benjamin Gilbert <bgilbert>
Status: CLOSED ERRATA QA Contact: Michael Nguyen <mnguyen>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.9CC: dornelas, jligon, mrussell, nstielau
Target Milestone: ---   
Target Release: 4.8.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 2004676
: 2004678 (view as bug list) Environment:
Last Closed: 2021-10-12 06:01:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1982001, 2004676    
Bug Blocks: 2004678    

Description RHCOS Bug Bot 2021-09-15 18:12:08 UTC
Backport the fix for bug 2004449 to 4.8.

Comment 1 Benjamin Gilbert 2021-09-17 17:27:29 UTC
Landed in 48.84.202109171500-0 for x86_64, and also in ppc64le and s390x (where that code path is not executed).  The aarch64 build does not yet include the cosa commit, but we don't ship that stream for 4.8.

Comment 2 RHCOS Bug Bot 2021-09-17 17:27:57 UTC
This bug has been reported fixed in a new RHCOS build.  Do not move this bug to MODIFIED until the fix has landed in a new bootimage.

Comment 3 RHCOS Bug Bot 2021-09-28 14:05:25 UTC
The fix for this bug has landed in a bootimage bump, as tracked in bug 1982001 (now in status MODIFIED).  Moving this bug to MODIFIED.

Comment 6 Michael Nguyen 2021-10-01 13:46:46 UTC
Verified on RHCOS 48.84.202109241901-0 which is in the boot image bump on OCP 4.8.0-0.nightly-2021-09-30-111446

$ sudo mount -o loop rhcos-48.84.202109241901-0-live.x86_64.iso /mnt/iso
mount: /var/mnt/iso: WARNING: source write-protected, mounted read-only.
$ sudo mount -o loop,ro /mnt/iso/images/efiboot.img /mnt/efi
$ tree /mnt/efi
/mnt/efi
└── EFI
    ├── BOOT
    │   ├── BOOTX64.EFI
    │   └── grubx64.efi
    └── redhat
        ├── fonts
        ├── grub.cfg
        ├── grubx64.efi
        ├── mmx64.efi
        ├── shimx64.efi
        └── shimx64-redhat.efi

Comment 8 errata-xmlrpc 2021-10-12 06:01:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.14 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3682