Bug 2008588

Summary: Machine-config controller fails to generate MC, when machine config pool with dashes in name presents under the cluster
Product: OpenShift Container Platform Reporter: Qi Wang <qiwan>
Component: NodeAssignee: Qi Wang <qiwan>
Node sub component: Kubelet QA Contact: Sunil Choudhary <schoudha>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: high CC: agurenko, alukiano, aos-bugs, dcain, jerzhang, minmli, nagrawal, oarribas, qiwan, saledort, schoudha, umohnani, william.caban
Version: 4.7   
Target Milestone: ---   
Target Release: 4.7.z   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1946584 Environment:
Last Closed: 2021-10-12 19:52:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1946584    
Bug Blocks:    

Comment 5 MinLi 2021-10-09 10:00:45 UTC
verified on 4.7.33.

$ oc get mc
NAME                                                   GENERATEDBYCONTROLLER                      IGNITIONVERSION   AGE
99-worker-cnf-generated-kubelet                        7688fcb20a553771a980cffd078da70908cf65a8   3.2.0             12m
99-worker-cnf-generated-kubelet-1                      7688fcb20a553771a980cffd078da70908cf65a8   3.2.0             23s

$ oc get mcp 
NAME         CONFIG                                                 UPDATED   UPDATING   DEGRADED   MACHINECOUNT   READYMACHINECOUNT   UPDATEDMACHINECOUNT   DEGRADEDMACHINECOUNT   AGE
master       rendered-master-8163a8bcbe63c2fd79f86fb7de33255a       True      False      False      3              3                   3                     0                      5h19m
worker       rendered-worker-f3ece06744eebe3cc5a25ca184376737       True      False      False      1              1                   1                     0                      5h19m
worker-cnf   rendered-worker-cnf-0931d30acb5b7d1098ebb5709da77ccc   True      False      False      2              2                   2                     0

$ oc get kubeletconfig cnf-pool -o yaml 
status:
  conditions:
  - lastTransitionTime: "2021-10-09T09:38:22Z"
    message: Success
    status: "True"
    type: Success

Comment 7 errata-xmlrpc 2021-10-12 19:52:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.33 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3686