Bug 2012855

Summary: [IPv6] rhcos-48.84.202109241901-0 is not taking IPv6 kernel parameters via iPXE
Product: OpenShift Container Platform Reporter: Pedro Amoedo <pamoedom>
Component: RHCOSAssignee: RHCOS Bug Triage <rhcos-triage>
Status: CLOSED NOTABUG QA Contact: Michael Nguyen <mnguyen>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.8CC: dornelas, jligon, lucab, mrussell, nstielau
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-10-11 16:28:28 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Comment 1 Luca BRUNO 2021-10-11 14:20:42 UTC
Thanks for the report!

> The nodes are ignoring the IPv6 configuration passed via kernel args, instead, they are setting an fe80:: link-local address on the corresponding interfaces.

I checked the logs for the bootstrap and master nodes, but I didn't see any custom kargs there.
So my understanding is that you are stating here that the kargs *in the PXE-booted environment* are not properly applied, I guess.
But I don't see any logs for that, so it's very hard to understand what's going on. If the problem you are facing stems from the PXE boot, please attach logs for that too.

> Not sure if this is relevant but nodes are showing a more recent RHCOS version (48.84.202110072059-0) that do not match with the same version from the images (rhcos-48.84.202109241901-0), is this expected?

That may be fine. If you are PXE-installing from older RHCOS botimages but using newer OCP content, the nodes will pivot to a matching OS version when joining the cluster.
You can double-check that via `rpm-ostree status` and the journal of `rpm-ostreed.service`, and cross-check the RHCOS version with the details of the OCP payload you are installing.

Comment 2 Pedro Amoedo 2021-10-11 14:39:34 UTC
Thanks for the quick response Luca, appreciated.

Regarding the different RHCOS version, you are right, the nodes simply pivoted to the most recent version via the MCO:

~~~
[core@master-00 ~]$ rpm-ostree status
State: idle
Deployments:
‚óŹ pivot://quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:2cce35e96f85e15ba5537635f4cbf8a1c0cb3d6041c48a19250b2e2c67f27680
              CustomOrigin: Managed by machine-config-operator
                   Version: 48.84.202110072059-0 (2021-10-07T21:02:47Z)

  ostree://13c18da5e6fee09fade484c3903209730cbb73e9ebcab806b9e9000cf97fd719
                   Version: 48.84.202109241901-0 (2021-09-24T19:04:29Z)
~~~

Regarding the iPXE boot logs, let me check if I can extract more info from the serial console and I'll get back to you ASAP.

Comment 4 Luca BRUNO 2021-10-12 06:49:31 UTC
The problem was a missing "--copy-network" in the custom coreos-installer hook. Not an RHCOS bug, closed.