Bug 2013088

Summary: The nodes page in the openshift console doesn't work. You just get a blank page
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: Management ConsoleAssignee: Jakub Hadvig <jhadvig>
Status: CLOSED ERRATA QA Contact: Yadan Pei <yapei>
Severity: high Docs Contact: Christopher Tauchen <ctauchen>
Priority: unspecified    
Version: 4.9CC: aos-bugs, ctauchen, jokerman, scuppett, spadgett, tnisan, yapei, yzamir
Target Milestone: ---Keywords: Regression
Target Release: 4.9.zFlags: yzamir: needinfo-
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: The nodes page is rendered before the list of nodes is available. Consequence: The nodes page crashes if it tries to render without nodes (e.g. before the list is available) and does not recover. Fix: Don't crash if list is empty, wait for a none-empty list and re-render. Result: The page does not crash when it tries to render before the nodes list is available. When the list is available it renders correctly.
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-10-26 17:22:42 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 2011809    
Bug Blocks:    

Comment 3 Yadan Pei 2021-10-14 06:48:27 UTC
PR has been tested and approved before merging, moving to VERIFIED directly

Comment 5 Yaacov Zamir 2021-10-14 18:42:24 UTC
doc text submited

Comment 9 errata-xmlrpc 2021-10-26 17:22:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.4 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3935