Bug 2013945

Summary: OCPonRHV: pvc stuck on pending status when using preallocated storage domain
Product: OpenShift Container Platform Reporter: Gal Zaidman <gzaidman>
Component: StorageAssignee: Gal Zaidman <gzaidman>
Storage sub component: oVirt CSI Driver QA Contact: michal <mgold>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: high CC: aos-bugs, gzaidman, jokerman, lleistne, mburman, mfojtik, mgold
Version: 4.8   
Target Milestone: ---   
Target Release: 4.8.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1985795 Environment:
Last Closed: 2021-11-02 14:42:06 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1985795    
Bug Blocks:    

Comment 5 michal 2021-10-26 11:21:26 UTC
rhv: 4.49
ocp: 4.8.0-0.nightly-2021-10-20-155651

steps: 
check this metric -

NFSx+Preallocated=Raw
SAN+Preallocated = Raw
SAN+Sparse = QCOW2
NFS+Sparse = Raw

I created NFS storage domain and check relevant cases with it,
also check in api that it creates the correct format.

1) create SC with ThisProvision = True/False and NFS/ISCSI 
2) create PVC for ths sc and check that there is no errors in log and it created in correct format

Comment 8 errata-xmlrpc 2021-11-02 14:42:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.18 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4020