Bug 201844

Summary: undefined symbol: cairo_xlib_surface_create
Product: [Fedora] Fedora Reporter: Bart Vanbrabant <bart.vanbrabant>
Component: cairoAssignee: Carl Worth <cworth>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: behdad, green, jwboyer, kdekorte, lmacken, pertusus, proski, seve141, usdanskys
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-08-09 15:20:01 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Bart Vanbrabant 2006-08-09 08:43:32 EDT
Description of problem:
The rawhide update of 20060809 has an error. When starting applications that
link against cairo I get this error: undefined symbol: cairo_xlib_surface_create
When reverting from cairo-1.2.2-1 to cairo-1.2.0-2 (and the pango packages
depending on it) the problem disappears.
Comment 1 Rex Dieter 2006-08-09 08:53:53 EDT
The full error (as reported to the fedora-devel) was:
symbol lookup error: /usr/lib/libgdk-x11-2.0.so.0: undefined symbol: 
cairo_xlib_surface_create

which implies the bug lies in gtk2 (I'd bet it at least needs to be rebuilt 
against the newer cairo).
Comment 2 Jens Petersen 2006-08-09 10:44:09 EDT
Looking at the -devel package it seems xlib support is missing.
Comment 3 Carl Worth 2006-08-09 11:30:04 EDT
This is a bug in cairo---specifically in its configure script.

Apparently it is now looking for X packages in a way that requires libXt present
in order for it to find X, (which is not helpful as cairo doesn't actually
require libXt at all). So the end result is that cairo is built without its xlib
backend.

Behdad wrote all the relevant code in the configure script, so I'm hoping he'll
be able to shed some light on what the fix should look like. Or if anybody has
some suggestions in the meantime, that would be good too.

-Carl
Comment 4 Ray Strode [halfline] 2006-08-09 15:20:01 EDT
For now, I've added libXt-devel as a build requirement and rebuild cairo.  So
things should be fixed up in tomorrow's rawhide.
Comment 5 ketan kothari 2006-08-09 15:31:54 EDT
(In reply to comment #4)
> For now, I've added libXt-devel as a build requirement and rebuild cairo.  So
> things should be fixed up in tomorrow's rawhide.

Do i have to wait till tomorrow and run yum update to fix this issue. I am not 
able to login to my gnome desktop. (Fedore Core 6 Test 2)
Comment 6 Ray Strode [halfline] 2006-08-09 15:35:51 EDT
I'll post rpms
Comment 7 ketan kothari 2006-08-09 15:37:51 EDT
(In reply to comment #6)
> I'll post rpms

Thanks. I will wait for the update.
Comment 8 Ray Strode [halfline] 2006-08-09 15:49:17 EDT
I've posted rpms here until tomorrow when the resync happens:

http://people.redhat.com/rstrode/cairo/
Comment 9 Herbert Carl Meyer 2006-08-09 16:10:06 EDT
Thanks for the fixes, Ray. System now works again.

Additional info: KDE desktop still worked, but Gnome apps like evolution would not start. KDM 
perhaps ?
Comment 10 Adam Jackson 2006-08-09 17:48:41 EDT
*** Bug 201859 has been marked as a duplicate of this bug. ***
Comment 11 Carl Worth 2006-08-09 18:42:22 EDT
*** Bug 201953 has been marked as a duplicate of this bug. ***
Comment 12 ketan kothari 2006-08-10 10:39:18 EDT
The new RPMS allowed me to start the Gnome Desktop. Basically after this bug, i
was unable to login to GNOME Desktop and screen will flash periodically with no
error messages. Basically made by computer unoperable. To fix this.

1. Login to root (Text mode by using GRUB), during the boot process select
append (a) and add 1 at the end. This will make system to start the text mode.

1. Start your network services if not already started and make yum download new
packages and install it.

Reboot the machine.