Bug 2019148 (CVE-2021-41183)

Summary: CVE-2021-41183 jquery-ui: XSS in *Text options of the datepicker widget
Product: [Other] Security Response Reporter: Guilherme de Almeida Suckevicz <gsuckevi>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: alazarot, anprice, anstephe, cfeist, cluster-maint, emarcus, emingora, etirelli, gblomqui, ibek, idevat, jrokos, jstastny, kmalyjur, krathod, kverlaen, mabashia, mattias.ellert, michal.skrivanek, mlisik, mnovotny, mperina, mpospisi, nobody, omular, pjindal, rguimara, rpetrell, rrajasek, sbonazzo, smcdonal, tojeline, tzimanyi
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-05-26 19:14:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 2019149, 2019150, 2019151, 2025456    
Bug Blocks: 2019158    

Description Guilherme de Almeida Suckevicz 2021-11-01 17:21:54 UTC
jQuery-UI is the official jQuery user interface library. Prior to version 1.13.0, accepting the value of various `*Text` options of the Datepicker widget from untrusted sources may execute untrusted code. The issue is fixed in jQuery UI 1.13.0. The values passed to various `*Text` options are now always treated as pure text, not HTML. A workaround is to not accept the value of the `*Text` options from untrusted sources.

Reference:
https://github.com/jquery/jquery-ui/security/advisories/GHSA-j7qv-pgf6-hvh4

Upstream patch:
https://github.com/jquery/jquery-ui/pull/1953

Comment 1 Guilherme de Almeida Suckevicz 2021-11-01 17:22:21 UTC
Created js-jquery-ui tracking bugs for this issue:

Affects: epel-all [bug 2019150]
Affects: fedora-all [bug 2019149]


Created pcs tracking bugs for this issue:

Affects: fedora-all [bug 2019151]

Comment 3 Garrett Tucker 2021-11-11 20:29:19 UTC
After review, RHEL is unaffected as there is no instance of pcs using the affected widget. While pcs does make use of jequery-ui, it is limited in usage and scope and there is no use of the datepicker widget or '*Text' option in pcs.

Comment 6 errata-xmlrpc 2022-05-26 16:22:17 UTC
This issue has been addressed in the following products:

  Red Hat Virtualization Engine 4.4

Via RHSA-2022:4711 https://access.redhat.com/errata/RHSA-2022:4711

Comment 7 Product Security DevOps Team 2022-05-26 19:14:01 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2021-41183