Bug 201953

Summary: All gtk programs broken: undefined symbol: cairo_xlib_surface_create
Product: [Fedora] Fedora Reporter: Pavel Roskin <proski>
Component: cairoAssignee: Carl Worth <cworth>
Status: CLOSED DUPLICATE QA Contact:
Severity: urgent Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-08-09 18:42:10 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Pavel Roskin 2006-08-09 18:18:33 EDT
Description of problem:

All programs linked to gtk2 for x86_64 or i386 fail to start:

$ gedit
gedit: symbol lookup error: /usr/lib64/libgdk-x11-2.0.so.0: undefined symbol: 
cairo_xlib_surface_create

$ firefox
/usr/local/firefox/firefox-bin: symbol lookup 
error: /usr/lib/libgdk-x11-2.0.so.0: undefined symbol: 
cairo_xlib_surface_create

$ rpm -qa |grep cairo
pycairo-devel-1.2.0-1.1.x86_64
cairo-devel-1.2.2-1.i386
cairo-devel-1.2.2-1.x86_64
cairo-1.2.2-1.x86_64
pycairo-1.2.0-1.1.x86_64
cairo-1.2.2-1.i386

$ rpm -q gedit
gedit-2.15.5-1.fc6.x86_64

Firefox is the latest nightly build for i386.

If gdm is used for login, it keeps restarting.

Version-Release number of selected component (if applicable):
cairo-1.2.2-1

How reproducible:
Always.  Forced uninstalling of cairo* and installing it by yum didn't help.

Steps to Reproduce:
1. "yum -y upgrade"
2. gedit
  
Actual results:
gedit fails:

gedit: symbol lookup error: /usr/lib64/libgdk-x11-2.0.so.0: undefined symbol: 
cairo_xlib_surface_create

Expected results:
gedit starts

Additional info:
I could recompile cairo for x86_64 (but only if freetype-devel-2.2.1-3.i386 is 
uninstalled).  It fixed gtk applications for x86_64.  I think cairo should 
just be rebuilt.  Please do it as soon as possible.
Comment 1 Carl Worth 2006-08-09 18:42:10 EDT

*** This bug has been marked as a duplicate of 201844 ***