Bug 2021963 (CVE-2021-3943, MSA-21-0038)

Summary: CVE-2021-3943 moodle: remote code execution risk when restoring malformed backup file
Product: [Other] Security Response Reporter: Guilherme de Almeida Suckevicz <gsuckevi>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED UPSTREAM QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: unspecifiedCC: gwync, igor.raits, security-response-team, sergio
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: moodle 3.11.4, moodle 3.10.8 and moodle 3.9.11 Doc Type: ---
Doc Text:
A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. A remote code execution risk when restoring backup files was identified.
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-11-16 16:32:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 2023825, 2023824    
Bug Blocks: 2021965    

Description Guilherme de Almeida Suckevicz 2021-11-10 13:30:29 UTC
A remote code execution risk when restoring backup files was identified.

Comment 1 Guilherme de Almeida Suckevicz 2021-11-16 16:20:13 UTC
Created moodle tracking bugs for this issue:

Affects: epel-7 [bug 2023825]
Affects: fedora-all [bug 2023824]

Comment 2 Product Security DevOps Team 2021-11-16 16:32:09 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.