Bug 2022399

Summary: MON_DISK_LOW troubleshooting guide link when clicked, gives 404 error .
Product: OpenShift Container Platform Reporter: Mugdha Soni <musoni>
Component: Console Storage PluginAssignee: Pranshu Srivastava <prasriva>
Status: CLOSED ERRATA QA Contact:
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.9CC: afrahman, aos-bugs, edonnell, muagarwa, nberry, nthomas, olakra, prasriva
Target Milestone: ---Flags: prasriva: needinfo-
Target Release: 4.10.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 2029297 (view as bug list) Environment:
Last Closed: 2022-03-10 16:26:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 2029297    

Description Mugdha Soni 2021-11-11 14:57:48 UTC
Description of problem:
----------------------------
The troubleshooting link which pops up for MON_DISK_LOW  when clicked , gives 404 error . 


Version-Release number of selected component (if applicable):
--------------------------------------------------------------
OCP :- 4.9
ODF :- 4.9

Steps to Reproduce:
--------------------------------------------------------------

In order to reproduce the warning as shown in the attached screenshot, you need to:
1. Install `fio` in one of the mon pods.
2. Fill up space in the associated PV by `fio --name=fio-rand-readwrite --filename=/var/lib/ceph/mon/ceph-b/fiofile --readwrite=randrw --bs=4K  --direct=1 --numjobs=1 --time_based=1 --runtime=3600000000 --size=40G --iodepth=8 --rwmixread=75 --ioengine=libaio` (if the pod belonged to the deployment called rook-ceph-mon-b).
3. Check the ODF dashboard and click on the Storage Cluster hyperlink to toggle the popover.

Actual results: 
Link redirect users to a new tab and gives 404 error.


Expected results: 
link should not give 404 error.

Comment 3 Pranshu Srivastava 2021-11-15 06:32:24 UTC
> If you still get 404, make sure you are logged into the customer portal, open a new tab, copy and paste the link and it should work.

@edonnell Is the link specified here (https://bugzilla.redhat.com/show_bug.cgi?id=2008321#c13) working for you? I tried the aforementioned steps and I still seem to get a 404. Can you please check?

Also, the link given here (https://issues.redhat.com/browse/RHSTOR-2060?focusedCommentId=19062579&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#comment-19062579) does not match the link here (https://bugzilla.redhat.com/show_bug.cgi?id=2008321#c13) even after removing the preview part (as mentioned in your BZ comment), please look into this. Nonetheless, the final link should be same as the one that's in master right now (see: https://github.com/openshift/console/blob/master/frontend/packages/ceph-storage-plugin/src/components/dashboards/persistent-internal/status-card/whitelisted-health-checks.ts#L5), which is same as the one defined in the JIRA link.

Thanks.

Comment 4 Pranshu Srivastava 2021-11-15 06:58:13 UTC
@nberry Depends on when the link is fixed, will keep this thread updated. Also, looping in Mudit as you asked (Nishant is already on the CC list here).

Comment 6 Pranshu Srivastava 2021-11-17 06:41:17 UTC
@edonnell Other than the "html" and "html-single" difference in the link, there's also one more place where the link differs (PTAL https://drive.google.com/file/d/1DZ09nJ17jyNPjsMfgbNZclZLGEEqX3ii/view?usp=sharing). This is fine, right? Just wanted to confirm before we merge this in master.

Thanks.

Comment 11 Pranshu Srivastava 2021-11-23 07:03:07 UTC
@

Comment 12 Pranshu Srivastava 2021-11-23 07:11:14 UTC
[Above comment was accidental, please ignore that.]

@edonnell I see the link above that you posted (for master) differs after "foundation" by "_rhocs" suffix. Is this intentional? If not, can this be fixed to point to what's in master at the moment?

Master link: https://access.redhat.com/documentation/en-us/red_hat_openshift_data_foundation/4.9/html/troubleshooting_openshift_data_foundation/troubleshooting-alerts-and-errors-in-openshift-data-foundation**_rhocs**#resolving-cluster-health-issues_rhodf
Proposed link: https://access.redhat.com/documentation/en-us/red_hat_openshift_data_foundation/4.9/html/troubleshooting_openshift_data_foundation/troubleshooting-alerts-and-errors-in-openshift-data-foundation#resolving-cluster-health-issues_rhodf

Thanks.

Comment 13 Pranshu Srivastava 2021-11-23 07:15:45 UTC
(Please note that the asterisks around "_rhocs" in the "Master link" above are not a part of the original link (that would make it an invalid link), but just there to make it easier to see the difference)

Comment 26 errata-xmlrpc 2022-03-10 16:26:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: OpenShift Container Platform 4.10.3 security update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2022:0056