Bug 20258

Summary: nmh not built with pop and mh-e broken
Product: [Retired] Red Hat Linux Reporter: nessus
Component: nmhAssignee: Florian La Roche <laroche>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 7.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-11-02 18:17:13 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description nessus 2000-11-02 18:17:11 EST
RedHat apparently doesn't compile POP support into 'nmh'.   This is a
shame, since I would think the vast majority of MH users would use it with
a POP server.   Also, it doesn't hurt anything to include POP support,
since if someone doesn't want to use POP, they don't have to, even if POP
support has been compiled in.

To get around this problem, I tried to build 'nmh' from RedHat's source
rpm.  To do this, I edited the "SPECS/nmh.spec" file so that the invocation
of the "configure" program included the flag "--enable-nmh-pop".  This has
worked for previous versions of nmh, but it didn't work this time.  The
build failed, complaining that it can't find a program called "libtoolize",
which I have never heard of and don't know where to find.

In summary, RedHat should compile 'nmh' with the "--enable-nmh-pop"
option.  And if not that, at least provide a source rpm that will actually
build.

In addition to this problem with nmh, 'mh-e', the Emacs interface to MH, is
broken.  If I try to use it, it complains that it can't find 'inc' or
'mhl'.  I can't even get it to tell me the version number without getting
this error message.  I know this is not a problem with my Emacs
configuration since I have been using mh-e for years and my 'mh-progs' and
'mh-lib' variables are set correctly.  To fix the problem, I fetched mh-e
version 5.0.2 from somewhere on the web and installed into the Emacs
lisp/mail directory.  As soon as I did this, everything worked fine.
Comment 1 Florian La Roche 2001-02-14 11:02:35 EST
Ok, pop support is added.