Bug 2025953

Summary: [RFE] The kickstart option --leavebootorder does not "leave boot order" on UEFI systems
Product: Red Hat Enterprise Linux 9 Reporter: Jiri Konecny <jkonecny>
Component: anacondaAssignee: Vladimír Slávik <vslavik>
Status: CLOSED ERRATA QA Contact: Release Test Team <release-test-team-automation>
Severity: medium Docs Contact: Sagar Dubewar <sdubewar>
Priority: urgent    
Version: 9.0CC: anaconda-maint-list, bootloader-eng-team, fmartine, jkonecny, jstodola, pjones, rblakley, release-test-team-automation, rharwood, sbarcomb, sbueno
Target Milestone: rcKeywords: FutureFeature, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: anaconda-34.25.0.25-1.el9 Doc Type: Bug Fix
Doc Text:
.`--leavebootorder` no longer changes boot order Previously, using `--leavebootorder` for the bootloader kickstart command did not work correctly on UEFI systems and changed the boot order. This caused the installer to add RHEL at the top of the list of installed systems in the UEFI boot menu. This update fixes the problem and using `--leavebootorder` no longer changes the boot order in the boot loader. `--leavebootorder` is now supported on RHEL for UEFI systems.
Story Points: ---
Clone Of: 1883224 Environment:
Last Closed: 2022-05-17 12:30:45 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1883224    
Bug Blocks:    
Deadline: 2022-01-25   

Comment 5 Vladimír Slávik 2021-11-26 15:38:54 UTC
PR with changes: https://github.com/rhinstaller/anaconda/pull/3726

Marked as "needs manual testing" due to need for testing on a real machine. The VMs we normally use do not persist UEFI vars or some such.

Comment 7 Vladimír Slávik 2021-11-30 18:02:40 UTC
PR is now marked as mergeable, waiting for a build so the QE can test.

Comment 12 Jan Stodola 2022-01-26 17:32:20 UTC
Confirmed with anaconda-34.25.0.25-1.el9 that:
* bootloader --leavebootorder in the kickstart file doesn't change the boot order
* inst.leavebootorder on the kernel command line doesn't change the boot order
* the boot order is changed and the system boots from disk if leavebootorder is not applied in kickstart or kernel cmdline

Tested on a physical UEFI machine.

Marking as Verified:Tested.

Comment 16 Jan Stodola 2022-01-28 16:34:00 UTC
Checked that anaconda-34.25.0.25-1.el9 is in nightly compose RHEL-9.0.0-20220127.4
Doc text and doc type matches.
No further testing is needed during verification based on comment 1

Moving to VERIFIED

Comment 18 errata-xmlrpc 2022-05-17 12:30:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (new packages: anaconda), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:2326