Bug 2026644

Summary: (release-4.9) Collect all the related container logs of a degraded cluster operator
Product: OpenShift Container Platform Reporter: Tomas Remes <tremes>
Component: Insights OperatorAssignee: Tomas Remes <tremes>
Status: CLOSED ERRATA QA Contact: Joao Fula <jfula>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.9CC: aos-bugs, dmisharo, hyagi, inecas, mklika, tremes
Target Milestone: ---   
Target Release: 4.9.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: 2002504
: 2026646 (view as bug list) Environment:
Last Closed: 2021-12-06 11:22:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 2002504    
Bug Blocks: 2026646    

Comment 2 Joao Fula 2021-11-30 09:30:43 UTC
Verified on 4.9.0-0.nightly-2021-11-29-233413.
 
Verification steps:

1. Disable Cluster Version Operator.
2. Degrade Cluster Monitoring Operator:
Edit "config.yaml" key value in "cluster-monitoring-config" config map of "openshift-monitoring" namespace.
Put any non-valid yaml there.
3. Wait until Cluster Monitoring Operator will be degraded:
oc get co
4. Restart Insights Operator
5. Wait until a new archive will be created.
6. Download the archive.

config/pod/openshift-monitoring/logs contains logs for all containers of "openshift-monitoring" namespace.

Comment 5 errata-xmlrpc 2021-12-06 11:22:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.10 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4889